summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2024-04-17 20:08:46 +0200
committerMartin Rys2024-04-17 20:08:46 +0200
commit85632e51e72a6b5337fbe08266660009ca11e45b (patch)
tree38a897b01d02e648c5a20c6e5fe721eeb4952f43
downloadaur-85632e51e72a6b5337fbe08266660009ca11e45b.tar.gz
Init v1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e94208f29a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = aax-bruteforce
+ pkgdesc = Bruteforce decrypt key for AAX files.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/MaxMatti/aax-bruteforce/
+ license = GPL-3.0-only
+ makedepends = clang
+ depends = gcc-libs
+ source = aax-bruteforce-1.0.tar.gz::https://github.com/MaxMatti/aax-bruteforce/archive/refs/tags/v1.0.tar.gz
+ source = aax-bruteforce-1.0-1.patch::https://github.com/MaxMatti/aax-bruteforce/pull/1.patch
+ sha256sums = 38cf551c060549932129ecf2878b9565273cea71c9145a6b9e19fe8488a3f47e
+ sha256sums = 23dc1f9e499105d5de93cdbace5f43f2fc060f10ea716a6e581eee2bc28e62a0
+
+pkgname = aax-bruteforce
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0857ffeb2023
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Martin Rys <rys.rs/contact>
+pkgname=aax-bruteforce
+pkgver=1.0
+_pkgver="v${pkgver}"
+pkgrel=1
+pkgdesc='Bruteforce decrypt key for AAX files.'
+arch=()
+url='https://github.com/MaxMatti/aax-bruteforce/'
+license=('GPL-3.0-only')
+groups=()
+depends=('gcc-libs')
+makedepends=('clang')
+replaces=()
+backup=()
+options=()
+install=
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/MaxMatti/${pkgname}/archive/refs/tags/${_pkgver}.tar.gz"
+ "${pkgname}-${pkgver}-1.patch::https://github.com/MaxMatti/aax-bruteforce/pull/1.patch")
+noextract=()
+sha256sums=('38cf551c060549932129ecf2878b9565273cea71c9145a6b9e19fe8488a3f47e'
+ '23dc1f9e499105d5de93cdbace5f43f2fc060f10ea716a6e581eee2bc28e62a0')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < "${srcdir}/${pkgname}-${pkgver}-1.patch" || true # README.md rejects
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 'main' "${pkgdir}/usr/bin/${pkgname}"
+}