summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2017-05-15 08:33:23 +0200
committerKarol Babioch2017-05-15 08:33:23 +0200
commit28f40c6b872d96c39b9fb72cce3b3b1451399c4d (patch)
tree74834c7c065ee521ce5de00f40dbbad2de0f1765
downloadaur-28f40c6b872d96c39b9fb72cce3b3b1451399c4d.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a57cdf76143
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aaxtomp3
+ pkgdesc = The purpose of this software is to convert AAX files to a more common MP3 format through a basic bash script frontend to FFMPEG.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/KrumpetPirate/AAXtoMP3
+ arch = any
+ license = custom
+ makedepends = git
+ depends = ffmpeg
+ depends = lame
+ source = aaxtomp3::git+https://github.com/KrumpetPirate/AAXtoMP3.git#tag=v1.0
+ sha256sums = SKIP
+
+pkgname = aaxtomp3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e90d88bda9f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Karol Babioch <karol@babioch.de
+
+pkgname=aaxtomp3
+pkgver=1.0
+pkgrel=1
+pkgdesc='The purpose of this software is to convert AAX files to a more common MP3 format through a basic bash script frontend to FFMPEG.'
+arch=('any')
+url='https://github.com/KrumpetPirate/AAXtoMP3'
+license=('custom')
+depends=('ffmpeg' 'lame')
+makedepends=('git')
+source=("$pkgname::git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ install -Dm 755 AAXtoMP3 "$pkgdir/usr/bin/AAXtoMP3"
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+