summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2017-05-15 08:42:18 +0200
committerKarol Babioch2017-05-15 08:42:18 +0200
commit02388fe436f5aee9334a971e8aa7460a925ef978 (patch)
tree972fbb3c4f6848239ac041325a12efa12ad0d287
parent568bfdab0b43afd783d63728be5f843d48597aea (diff)
downloadaur-02388fe436f5aee9334a971e8aa7460a925ef978.tar.gz
Use tags as pkgver
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 133ab619954b..d572e6e1142e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karol Babioch <karol@babioch.de
pkgname=aaxtomp3-git
-pkgver=r38.48e2eeb
+pkgver=v1.0.r0.gd96d01e
pkgrel=1
pkgdesc='The purpose of this software is to convert AAX files to a more common MP3 format through a basic bash script frontend to FFMPEG.'
arch=('any')
@@ -16,12 +16,11 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
cd "$srcdir/$pkgname"
-
install -Dm 755 AAXtoMP3 "$pkgdir/usr/bin/AAXtoMP3"
install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"