summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Danov2022-09-13 22:38:03 +0300
committerViktor Danov2022-09-13 22:38:03 +0300
commit1eafb166e18ef4cfe8892f44cf63682e42b5cec1 (patch)
tree31018a6894c69c48c83d1bfb26e7b5d7b0168c2f
parent1eaf4482e6fc4ce0f9195550574c963feddcaf3a (diff)
downloadaur-1eafb166e18ef4cfe8892f44cf63682e42b5cec1.tar.gz
clean up junk
-rw-r--r--.SCRINFO20
-rw-r--r--Makefile4
-rw-r--r--install.sh65
-rw-r--r--layout-evdev-install.hook9
-rw-r--r--layout-evdev-remove.hook9
-rw-r--r--level3_np8
-rw-r--r--np69
-rw-r--r--uninstall.sh38
-rw-r--r--windscribe-bin.install52
9 files changed, 0 insertions, 274 deletions
diff --git a/.SCRINFO b/.SCRINFO
deleted file mode 100644
index cb0e7f665206..000000000000
--- a/.SCRINFO
+++ /dev/null
@@ -1,20 +0,0 @@
-pkgbase = satania-buddy-git
- pkgdesc = Virtual Satania Desktop Assistant
- pkgver = r68.ade3a6f
- pkgrel = 1
- url = https://git.cianig.ga/monkeyballs/sataniabuddy
- arch = x86_64
- arch = i686
- license = AGPL
- makedepends = git
- makedepends = make
- makedepends = gcc
- depends = openmotif
- depends = cairo
- depends = xorg-server
- provides = satania-buddy
- conflicts = satania-buddy
- source = git+https://git.cianig.ga/monkeyballs/sataniabuddy
- md5sums = SKIP
-
-pkgname = satania-buddy-git
diff --git a/Makefile b/Makefile
deleted file mode 100644
index 1c6ff6c13c95..000000000000
--- a/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-install:
- cp level3_np $(DESTDIR)/usr/share/X11/xkb/symbols/
- cp np $(DESTDIR)/usr/share/X11/xkb/symbols/np_prog
- bash install.sh
diff --git a/install.sh b/install.sh
deleted file mode 100644
index 4491f489c700..000000000000
--- a/install.sh
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/usr/bin/env bash
-
-set -euxo pipefail
-
-TMP_DIR=/tmp/nekuvi/
-
-copy_files() {
- mkdir -p "$TMP_DIR"
- cp /usr/share/X11/xkb/rules/evdev.lst "$TMP_DIR"
- cp /usr/share/X11/xkb/rules/evdev.xml "$TMP_DIR"
-}
-
-append_evdev_lst() {
- pushd "$TMP_DIR"
-
- if grep -q "np_prog" evdev.lst; then
- echo "WARNING: evdev.lst already updated. This could mean that you may have tried to install this package previously. Continuing installation."
- else
- sed -i '/! layout/a \ \ np_prog \t Nepali for programmers' evdev.lst
- fi
- popd
-}
-
-append_evdev_xml() {
- pushd "$TMP_DIR"
- read -r -d '' np_prog_layout <<EOF || true
-<!-- BEGIN np_prog -->
- <layout>
- <configItem>
- <name>np_prog</name>
-
- <shortDescription>np_prog</shortDescription>
- <description>Nepali for programmers</description>
- <languageList>
- <iso639Id>nep</iso639Id>
- </languageList>
- </configItem>
- </layout>
-<!-- END np_prog -->
-EOF
-
- if grep -q "np_prog" evdev.xml; then
- echo "WARNING: evdev.lst already updated. This could mean that you may have tried to install this package previously. Continuing installation."
- else
- awk -v layout="$np_prog_layout" '{ print } /<layoutList>/ { print layout }' evdev.xml > temp.xml
- cp temp.xml evdev.xml
- fi
- popd
-}
-
-install_evdev() {
- pushd "$TMP_DIR"
- cp evdev.* /usr/share/X11/xkb/rules/
- popd
-}
-
-process() {
- copy_files # copies the necessary files to a temp dir for us
- append_evdev_lst # modify evdev.lst with np_prog
- append_evdev_xml # add np_prog to evdev.xml
- install_evdev
-}
-
-
-process
diff --git a/layout-evdev-install.hook b/layout-evdev-install.hook
deleted file mode 100644
index 3e58409c802c..000000000000
--- a/layout-evdev-install.hook
+++ /dev/null
@@ -1,9 +0,0 @@
-[Trigger]
-Type = Package
-Operation = Install
-Operation = Upgrade
-Target = nekuvi
-[Action]
-When = PostTransaction
-Description = Adding evdev rules for np_prog...
-Exec = /usr/share/libalpm/scripts/install-nekuvi-layout
diff --git a/layout-evdev-remove.hook b/layout-evdev-remove.hook
deleted file mode 100644
index d730190bf8ea..000000000000
--- a/layout-evdev-remove.hook
+++ /dev/null
@@ -1,9 +0,0 @@
-[Trigger]
-Type = Package
-Operation = Remove
-Target = nekuvi
-
-[Action]
-Description = Removing evdev rules for np_prog...
-When = PreTransaction
-Exec = /usr/share/libalpm/scripts/uninstall-nekuvi-layout
diff --git a/level3_np b/level3_np
deleted file mode 100644
index 6e7416deabd2..000000000000
--- a/level3_np
+++ /dev/null
@@ -1,8 +0,0 @@
-partial modifier_keys
-xkb_symbols "caps_switch_latch" {
- key <CAPS> {
- type[Group1]="THREE_LEVEL",
- symbols[Group1] = [ ISO_Level3_Latch, ISO_Level3_Shift, ISO_Level3_Latch ]
- };
- include "level3(modifier_mapping)"
-};
diff --git a/np b/np
deleted file mode 100644
index eaedf2a4c535..000000000000
--- a/np
+++ /dev/null
@@ -1,69 +0,0 @@
-// based on a keyboard map from an 'xkb/symbols/dev' file
-
-default partial alphanumeric_keys xkb_symbols "phenotic" {
- name[Group1]= "Nepali (Phenotic)";
-
- key.type="FOUR_LEVEL";
-
-// `,1,2,3,4,5,6,7,8,9,0,-,=
-
- key <TLDE> { [ 0x100093D, 0x100097D, grave, asciitilde ] };
- key <AE01> { [ 0x1000967, exclam, 1, exclam ] };
- key <AE02> { [ 0x1000968, at, 2, at ] };
- key <AE03> { [ 0x1000969, numbersign, 3, numbersign ] };
- key <AE04> { [ 0x100096A, 0x10020A8, 4, dollar ] };
- key <AE05> { [ 0x100096B, percent, 5, percent ] };
- key <AE06> { [ 0x100096C, asciicircum, 6, asciicircum ] };
- key <AE07> { [ 0x100096D, ampersand, 7, ampersand ] };
- key <AE08> { [ 0x100096e, asterisk, 8, asterisk ] };
- key <AE09> { [ 0x100096F, parenleft, 9, parenleft ] };
- key <AE10> { [ 0x1000966, parenright, 0, parenright ] };
- key <AE11> { [ minus, underscore ] };
- key <AE12> { [ equal, plus ] };
-
-// q,w,e,r,t,y,u,i,o,p,[,]
-
- key <AD01> { [ 0x100091F, 0x1000920, q, Q ] };
- key <AD02> { [ 0x100094C, 0x1000914, w, W ] };
- key <AD03> { [ 0x1000947, 0x1000948, e, E ] };
- key <AD04> { [ 0x1000930, 0x1000943, r, R ] };
- key <AD05> { [ 0x1000924, 0x1000925, t, T ] };
- key <AD06> { [ 0x100092F, 0x100091E, y, Y ] };
- key <AD07> { [ 0x1000941, 0x1000942, u, U ] };
- key <AD08> { [ 0x100093F, 0x1000940, i, I ] };
- key <AD09> { [ 0x100094B, 0x1000913, o, O ] };
- key <AD10> { [ 0x100092A, 0x100092B, p, P ] };
- key <AD11> { [ 0x1000907, 0x1000908, bracketleft, braceleft ] };
- key <AD12> { [ 0x100090F, 0x1000910, bracketright, braceright] };
-
-// a,s,d,f,g,h,j,k,l,;,',Backslash
- key <AC01> { [ 0x100093E, 0x1000906, a, A ] };
- key <AC02> { [ 0x1000938, 0x1000936, s, S ] };
- key <AC03> { [ 0x1000926, 0x1000927, d, D ] };
- key <AC04> { [ 0x1000909, 0x100090A, f, F ] };
- key <AC05> { [ 0x1000917, 0x1000918, g, G ] };
- key <AC06> { [ 0x1000905, 0x1000939, h, H ] };
- key <AC07> { [ 0x100091C, 0x100091D, j, J ] };
- key <AC08> { [ 0x1000915, 0x1000916, k, K ] };
- key <AC09> { [ 0x1000932, 0x1000933, l, L ] };
- key <AC10> { [ semicolon, colon, semicolon, colon ] };
- key <AC11> { [ apostrophe, quotedbl, apostrophe, quotedbl ] };
- key <BKSL> { [ 0x1000950, 0x1000903, backslash, bar ] };
-
-
-// z,x,c,v,b,n,m,,,.,/
- key <AB01> { [ 0x1000937, 0x100090B, z, Z ] };
- key <AB02> { [ 0x1000921, 0x1000922, x, X ] };
- key <AB03> { [ 0x100091A, 0x100091B, c, C ] };
- key <AB04> { [ 0x1000935, 0x1000901, v, V ] };
- key <AB05> { [ 0x100092C, 0x100092D, b, B ] };
- key <AB06> { [ 0x1000928, 0x1000923, n, N ] };
- key <AB07> { [ 0x100092E, 0x1000902, m, M ] };
- key <AB08> { [ comma, 0x1000919, comma, less ] };
- key <AB09> { [ 0x1000964, 0x1000965, period, greater ] };
- key <AB10> { [ 0x100094D, question, slash, question ] };
-
- include "level3(caps_switch)"
- include "level3(caps_switch_latch)"
-
-};
diff --git a/uninstall.sh b/uninstall.sh
deleted file mode 100644
index 623a51bae924..000000000000
--- a/uninstall.sh
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/usr/bin/env bash
-
-set -euxo pipefail
-
-TMP_DIR=/tmp/nekuvi/
-
-copy_files() {
- mkdir -p "$TMP_DIR"
- cp /usr/share/X11/xkb/rules/evdev.lst "$TMP_DIR"
- cp /usr/share/X11/xkb/rules/evdev.xml "$TMP_DIR"
-}
-
-remove_evdev_lst() {
- pushd "$TMP_DIR"
- sed -i '/np_prog/d' evdev.lst
-}
-
-remove_evdev_xml() {
- pushd "$TMP_DIR"
- sed -i '/BEGIN np_prog/,/END np_prog/d' evdev.xml
- popd
-}
-
-uninstall_evdev() {
- pushd "$TMP_DIR"
- cp evdev.* /usr/share/X11/xkb/rules/
- popd
-}
-
-process() {
- copy_files # copies the necessary files to a temp dir for us
- remove_evdev_lst # modify evdev.lst with np_prog
- remove_evdev_xml # add np_prog to evdev.xml
- uninstall_evdev
-}
-
-
-process
diff --git a/windscribe-bin.install b/windscribe-bin.install
deleted file mode 100644
index 252f0fa51bb3..000000000000
--- a/windscribe-bin.install
+++ /dev/null
@@ -1,52 +0,0 @@
-pre_install() {
-
- end=$((SECONDS+10))
-
- while :
- do
- if [ -z "$(ps -eo args | grep WindscribeEngine | grep -v grep)" ]; then
- break
- fi
-
- if [ $SECONDS -gt $end ]; then
- echo 'Error during Windscribe installation. WindscribeEngine is running. Please re-launch Windscribe. And try to update again.'
- exit 1
- fi
- done
-
- systemctl stop windscribe-helper > /dev/null 2>&1
- systemctl disable windscribe-helper > /dev/null 2>&1
-
- # Stop and disable firewalld service if it is active, otherwise it will conflict with iptables on OS reboot
- # Relevant for Fedora distributions
- systemctl is-active --quiet firewalld
- if [ $? -eq 0 ]
- then
- echo "Firewalld service is running. It will be stopped and disabled to avoid conflicts with the Windscribe iptables firewall."
- sudo systemctl stop firewalld
- sudo systemctl disable firewalld
- fi
-
- echo "Finish pre-install script"
-}
-
-post_install() {
- systemctl enable windscribe-helper
- systemctl start windscribe-helper
-
-}
-
-pre_upgrade() {
- set -e
- systemctl stop windscribe-helper
- systemctl disable windscribe-helper
-}
-
-post_upgrade() {
- post_install
-}
-
-pre_remove() {
- systemctl stop windscribe-helper
- systemctl disable windscribe-helper
-}