diff options
author | NexAdn | 2021-12-13 23:16:57 +0100 |
---|---|---|
committer | Javier Sánchez Parra | 2021-12-14 18:34:24 +0100 |
commit | 13d4898815b585b17179e857f81b84a301a6956c (patch) | |
tree | 61ba671adda3bdc84c3d536781b9d09f76990cf2 | |
parent | 514d4a6a59a82020b012c03982ea0ed77f54cedd (diff) | |
download | aur-13d4898815b585b17179e857f81b84a301a6956c.tar.gz |
Remove wrapper for starting abaddon
Since abaddon supports the creation of a config file in the users home
directory (more specifically, `pwd`), the highly insecure approach of
saving the configuration in a system-wide accessible (umask 0111)
directory shall be removed.
This commit removes the wrapper script completely and installs abaddon
directly to /usr/bin and removes installing a blank config file with
umask 0111 to /opt/abaddon.
THIS IS A BREAKING CHANGE. Removing the wrapper script (and as a
consequence the cwd in which abaddon is being executed) makes abaddon
unable to find the config file if users don't move the current config
file to their new cwd (i.e. usually their $HOME) and as a consequence
causes settings to be (seemingly) lost. Maybe, a migration mechanism can
be implemented, but would require at least two relbumps.
Signed-off-by: NexAdn <nex@nexadn.de>
-rw-r--r-- | PKGBUILD | 8 |
1 files changed, 0 insertions, 8 deletions
@@ -34,12 +34,4 @@ package() { install -d "$pkgdir"/usr/share/abaddon/fonts cp -r "$pkgname"/res/fonts/* "$pkgdir"/usr/share/abaddon/fonts/ - install -Dm666 /dev/null "$pkgdir"/opt/abaddon/abaddon.ini - - install -Dm755 /dev/null "$pkgdir"/usr/bin/abaddon - cat - > "$pkgdir"/usr/bin/abaddon <<EOF -#!/bin/sh -cd /opt/abaddon -./abaddon $@ -EOF } |