summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Sánchez Parra2023-06-12 12:04:20 +0200
committerJavier Sánchez Parra2023-06-12 12:05:29 +0200
commitf84bf6dad235b99d4a4c5ca4b467195260dc6632 (patch)
treee7ca00e1e790bc4b616e51a858d9ed2bf936eda5
parent575de6c1ee3e3e43a26674f687097f8837641767 (diff)
downloadaur-f84bf6dad235b99d4a4c5ca4b467195260dc6632.tar.gz
v0.1.11
* Add dependencies: spdlog, opus, libsodium. * Remove workaround.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 588657dce8bd..c25b905e72e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = abaddon
pkgdesc = An alternative Discord client made with C++/gtkmm
- pkgver = 0.1.10
- pkgrel = 2
+ pkgver = 0.1.11
+ pkgrel = 1
url = https://github.com/uowuo/abaddon
arch = x86_64
license = GPL3
@@ -10,9 +10,12 @@ pkgbase = abaddon
makedepends = nlohmann-json
depends = gtkmm3
depends = libhandy
+ depends = spdlog
+ depends = opus
+ depends = libsodium
provides = abaddon
conflicts = abaddon
- source = git+https://github.com/uowuo/abaddon#tag=v0.1.10
+ source = git+https://github.com/uowuo/abaddon#tag=v0.1.11
source = abaddon.desktop
sha256sums = SKIP
sha256sums = 7840732362b8f2202cf79b7d7c2eb0e2cbd5a83dc45c5fca4609ec15b8bea6df
diff --git a/PKGBUILD b/PKGBUILD
index 1cb51dd4ad18..bac703129310 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Contributor: NexAdn <git@nexadn.de>
# Maintainer: javsanpar <javsanpar@riseup.net>
pkgname=abaddon
-pkgver=0.1.10
-pkgrel=2
+pkgver=0.1.11
+pkgrel=1
pkgdesc='An alternative Discord client made with C++/gtkmm'
url='https://github.com/uowuo/abaddon'
source=("git+https://github.com/uowuo/abaddon#tag=v$pkgver"
@@ -10,7 +10,7 @@ source=("git+https://github.com/uowuo/abaddon#tag=v$pkgver"
arch=('x86_64')
license=('GPL3')
makedepends=('git' 'cmake' 'nlohmann-json')
-depends=('gtkmm3' 'libhandy')
+depends=('gtkmm3' 'libhandy' 'spdlog' 'opus' 'libsodium')
conflicts=('abaddon')
provides=('abaddon')
sha256sums=('SKIP'
@@ -22,12 +22,6 @@ prepare () {
git submodule update --init subprojects/ixwebsocket/
git submodule update --init subprojects/keychain/
git submodule update --init subprojects/miniaudio/
-
- # Temporal workaround to fix compilation issues with the commit used in
- # release v0.1.10
- pushd subprojects/ixwebsocket
- git checkout bc765e7
- popd
}
build () {