summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrent Carmer2019-09-05 13:21:53 -0700
committerBrent Carmer2019-09-05 13:21:53 -0700
commita441b0beaa3e93e55d83908f20840d02b8b57ddc (patch)
tree9e88afb47cd850341dfea866bd38ae972c18b2d9
downloadaur-a441b0beaa3e93e55d83908f20840d02b8b57ddc.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1a561665431
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = abc-hg
+ pkgdesc = System for Sequential Logic Synthesis and Formal Verification
+ pkgver = r.
+ pkgrel = 1
+ url = http://www.eecs.berkeley.edu/~alanmi/abc/abc.htm
+ arch = x86_64
+ arch = i686
+ license = BSD
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ provides = abc
+ conflicts = abc
+ source = git+https://github.com/berkeley-abc/abc.git
+ md5sums = SKIP
+
+pkgname = abc-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f832816691eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Brent Carmer <bcarmer@gmail.com>
+_pkgname=abc
+pkgname=$_pkgname-hg
+
+pkgver=r.
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+pkgrel=1
+pkgdesc="System for Sequential Logic Synthesis and Formal Verification"
+url="http://www.eecs.berkeley.edu/~alanmi/abc/abc.htm"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=()
+makedepends=('git' 'make' 'gcc')
+optdepends=()
+conflicts=()
+replaces=()
+backup=()
+conflicts=('abc')
+provides=('abc')
+md5sums=('SKIP')
+
+source=('git+https://github.com/berkeley-abc/abc.git')
+
+build() {
+ cd $srcdir/$_pkgname
+ make -j
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cd $srcdir/$_pkgname
+ cp abc $pkgdir/usr/bin
+}