summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrZingo2021-06-03 16:58:08 +0200
committerDrZingo2021-06-03 16:58:08 +0200
commit1fc5c0cee1ad865a5e0290ae9878c78960b95124 (patch)
treea60d838c0f3841fff5cd581a85c8b274962f21a0
downloadaur-1fc5c0cee1ad865a5e0290ae9878c78960b95124.tar.gz
First commit abc80sim-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55519d1eb484
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = abc80sim-git
+ pkgdesc = An X windows based emulator of a Luxor ABC80
+ pkgver = r431.067a8ad
+ pkgrel = 1
+ url = https://git.zytor.com/abc80/abc80sim.git
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = sdl
+ source = git+https://git.zytor.com/abc80/abc80sim.git
+ md5sums = SKIP
+
+pkgname = abc80sim-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e55e22d293ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: DrZingo <markus at borgelin dot org>
+
+_pkgname=abc80sim
+pkgname=abc80sim-git
+pkgver=r431.067a8ad
+pkgrel=1
+pkgdesc="An X windows based emulator of a Luxor ABC80"
+url="https://git.zytor.com/abc80/abc80sim.git"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('sdl')
+makedepends=('git')
+source=('git+https://git.zytor.com/abc80/abc80sim.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${srcdir}/${_pkgname}
+ git checkout master
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+
+ install -D abc80 $pkgdir/usr/bin/abc80
+ install -Dm644 abc80.man $pkgdir/usr/share/man/man1/abc80.1
+ #make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=4 sw=4 et: