summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-07-08 21:50:21 +0000
committerFlorian Hülsmann2022-07-08 21:50:21 +0000
commitcdd45aba562cad830fec8f8a99fb6e30dc220f51 (patch)
tree61ff5106939ed782100950da3a767fc1d1fbda1d
parenteedf46450135e5ec34e3391b7a1217427fe1af17 (diff)
downloadaur-cdd45aba562cad830fec8f8a99fb6e30dc220f51.tar.gz
bump some pkgrels to trigger AUR updates and debug builds (#89)
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD37
3 files changed, 41 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 601c03a8d11c..4df6bd304476 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,27 @@
pkgbase = abcm2ps
- pkgdesc = Convert ABC music notation files to PostScript from the commandline
+ pkgdesc = Convert ABC music notation files to PostScript from the command line
pkgver = 8.14.13
- pkgrel = 1
+ pkgrel = 3
url = http://moinejf.free.fr/
- arch = i686
arch = x86_64
+ arch = aarch64
groups = abc
+ groups = pro-audio
license = GPL3
+ checkdepends = adobe-source-han-sans-cn-fonts
+ makedepends = freetype2
+ makedepends = glib2
+ makedepends = pango
makedepends = python-docutils
- depends = pango
- conflicts = abcm2ps-devel
+ depends = glibc
source = abcm2ps-8.14.13.tar.gz::https://github.com/lewdlime/abcm2ps/archive/v8.14.13.tar.gz
sha256sums = 8db29e33f30fce609ddffeb641c3bfe60ae5d16c3305402157ddc88bcaaf0c5b
pkgname = abcm2ps
+ depends = glibc
+ depends = libpangocairo-1.0.so
+ depends = libpangoft2-1.0.so
+ depends = libpango-1.0.so
+ depends = libgobject-2.0.so
+ depends = libglib-2.0.so
+ depends = libfreetype.so
diff --git a/.gitignore b/.gitignore
index a5cd16124ef2..57e7fd90984f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,4 @@
pkg/
src/
-abcm2ps-*.tar.gz
-abcm2ps-*.pkg.tar.xz
-abcm2ps-*.pkg.tar.zst
-abcm2ps-*.src.tar.gz
-.AURINFO
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 8e39d6b0b9da..75401d5b579f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
# Contributor: Tuyen Pham <tuyenpm9@gmail.com>
# Contributor: Lex Black <autumn-wind@web.de>
# Contributor: Simon Thorpe <simon@hivetechnology.com.au>
@@ -8,25 +9,33 @@
pkgname=abcm2ps
pkgver=8.14.13
-pkgrel=1
-pkgdesc="Convert ABC music notation files to PostScript from the commandline"
-arch=('i686' 'x86_64')
-url="http://moinejf.free.fr/"
-license=('GPL3')
-depends=('pango')
-makedepends=('python-docutils')
-conflicts=('abcm2ps-devel')
-groups=('abc')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/lewdlime/${pkgname}/archive/v${pkgver}.tar.gz)
+pkgrel=3
+pkgdesc='Convert ABC music notation files to PostScript from the command line'
+arch=(x86_64 aarch64)
+url='http://moinejf.free.fr/'
+license=(GPL3)
+depends=(glibc)
+makedepends=(freetype2 glib2 pango python-docutils)
+checkdepends=(adobe-source-han-sans-cn-fonts)
+groups=(abc pro-audio)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/lewdlime/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('8db29e33f30fce609ddffeb641c3bfe60ae5d16c3305402157ddc88bcaaf0c5b')
build() {
- cd "${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
./configure --prefix=/usr
make
}
+check() {
+ cd $pkgname-$pkgver
+ rm -f *.ps
+ make -j1 test
+}
+
package() {
- cd "${pkgname}-${pkgver}"
- make prefix="$pkgdir/usr" docdir=$pkgdir/usr/share/doc install
+ depends+=(libpangocairo-1.0.so libpangoft2-1.0.so libpango-1.0.so
+ libgobject-2.0.so libglib-2.0.so libfreetype.so)
+ cd $pkgname-$pkgver
+ make prefix="$pkgdir"/usr docdir="$pkgdir"s/usr/share/doc install
}