summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Thorpe2015-08-27 04:43:07 +0000
committerSimon Thorpe2015-08-27 04:43:07 +0000
commitffb75a343d4896b73cc6ec2480abe377441a3a8f (patch)
tree043d1cd9b36bb78be96f285eba48f3e331d0fa73
downloadaur-ffb75a343d4896b73cc6ec2480abe377441a3a8f.tar.gz
7.8.14-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae2226c0c1a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = abcm2ps
+ pkgdesc = Convert ABC music notation files to PostScript from the commandline
+ pkgver = 7.8.14
+ pkgrel = 1
+ url = http://moinejf.free.fr/
+ arch = i686
+ arch = x86_64
+ groups = abc
+ license = GPL
+ depends = pango
+ depends = freetype2
+ conflicts = abcm2ps-devel
+ source = http://moinejf.free.fr/abcm2ps-7.8.14.tar.gz
+ sha256sums = 31c55865a914d56c12e2b7cbeaf5e4a09b47bbe79f1c7b5cd1576a16f3753d07
+
+pkgname = abcm2ps
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20de942008ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Simon Thorpe <simon@hivetechnology.com.au>
+# Contributor: kess <joe@macmahon.eu>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: Luis Pablo Gasparotto <lpgasparotto(at)gmail(dot)com>
+
+pkgname=abcm2ps
+pkgver=7.8.14
+pkgrel=1
+pkgdesc="Convert ABC music notation files to PostScript from the commandline"
+arch=('i686' 'x86_64')
+url="http://moinejf.free.fr/"
+license=('GPL')
+depends=('pango' 'freetype2')
+conflicts=('abcm2ps-devel')
+groups=(abc)
+source=(http://moinejf.free.fr/$pkgname-$pkgver.tar.gz)
+sha256sums=('31c55865a914d56c12e2b7cbeaf5e4a09b47bbe79f1c7b5cd1576a16f3753d07')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make prefix="$pkgdir/usr" docdir=$pkgdir/usr/share/doc install
+} \ No newline at end of file