summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Sutton2020-06-02 10:43:22 +0100
committerPeter Sutton2020-06-02 10:43:22 +0100
commit081e294e844c694a8d87c5ce1145cd4693e51ddd (patch)
tree4225cba85a0f0314ed86ccefde1a202ed4ba73b5
parent0850b5e14a4ce10e1071463a84a4535a489bbe0a (diff)
downloadaur-081e294e844c694a8d87c5ce1145cd4693e51ddd.tar.gz
Upstream release & build patch
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD18
-rw-r--r--parseabc.patch4
4 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67b9ba84e89e..f520dc81d562 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = abcmidi
pkgdesc = A set of tools for converting ABC files to MIDI files and vice versa, as well as other small utilities
- pkgver = 20200212
+ pkgver = 20200506
pkgrel = 1
url = https://ifdo.ca/~seymour/runabc/top.html
changelog = ChangeLog
arch = x86_64
license = GPL
- source = https://ifdo.ca/~seymour/runabc/abcMIDI-2020.02.12.zip
- sha256sums = 749032907b8f8b7d06701c61b28dc0d845e72cf8eb44fc7cd139c9b5be286723
+ source = parseabc.patch
+ source = https://ifdo.ca/~seymour/runabc/abcMIDI-2020.05.06.zip
+ sha256sums = 6fda05d5ddd6ce97de3a54048bb6f20400045eb3fbd646e2f43fed0aa6992d53
+ sha256sums = 69939ef6d331c0d920b3a7a2834b1fca6ba0e6da867b6f960b222c0b9861545f
pkgname = abcmidi
diff --git a/.gitignore b/.gitignore
index 4be3945ea4a3..427f417d0516 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
-*
-!/.gitignore
-!/ChangeLog
-!/PKGBUILD
+/*.pkg.*
+/.ccls-cache/
+/abcMIDI-*.zip
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index 5d3059ac4899..f67367c5e084 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,27 @@
# Maintainer: Peter Sutton <peter@foxdogstudios.com>
_pkgver_year=2020
-_pkgver_month=02
-_pkgver_day=12
+_pkgver_month=05
+_pkgver_day=06
pkgname=abcmidi
-pkgver="${_pkgver_year}${_pkgver_month}${_pkgver_day}"
+pkgver=$_pkgver_year$_pkgver_month$_pkgver_day
pkgrel=1
-pkgdesc="A set of tools for converting ABC files to MIDI files and vice versa, as well as other small utilities"
+pkgdesc='A set of tools for converting ABC files to MIDI files and vice versa, as well as other small utilities'
url="https://ifdo.ca/~seymour/runabc/top.html"
license=('GPL')
depends=()
makedepends=()
changelog=ChangeLog
-source=("https://ifdo.ca/~seymour/runabc/abcMIDI-${_pkgver_year}.${_pkgver_month}.${_pkgver_day}.zip")
+source=('parseabc.patch'
+ "https://ifdo.ca/~seymour/runabc/abcMIDI-${_pkgver_year}.${_pkgver_month}.${_pkgver_day}.zip")
arch=(x86_64)
-sha256sums=('749032907b8f8b7d06701c61b28dc0d845e72cf8eb44fc7cd139c9b5be286723')
+sha256sums=('6fda05d5ddd6ce97de3a54048bb6f20400045eb3fbd646e2f43fed0aa6992d53'
+ '69939ef6d331c0d920b3a7a2834b1fca6ba0e6da867b6f960b222c0b9861545f')
+
+prepare() {
+ patch "$srcdir"/abcmidi/parseabc.c "$srcdir"/parseabc.patch
+}
build() {
cd "$srcdir"/abcmidi
diff --git a/parseabc.patch b/parseabc.patch
new file mode 100644
index 000000000000..7f89fb03f69e
--- /dev/null
+++ b/parseabc.patch
@@ -0,0 +1,4 @@
+88c88
+< int ingrace = 0;
+---
+> static int ingrace = 0;