summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Sutton2015-06-20 13:53:25 +0100
committerPeter Sutton2015-06-20 13:53:25 +0100
commitf76b0a641d8045c41bdd8edc2a5a19eba4e107fd (patch)
tree93753603fdbc7184eb463db2aac821f81c8fd1ba
downloadaur-f76b0a641d8045c41bdd8edc2a5a19eba4e107fd.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--ChangeLog45
-rw-r--r--PKGBUILD40
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd772870ce12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = abcmidi
+ pkgdesc = A set of tools for converting ABC files to MIDI files and vice versa, as well as other small utilities
+ pkgver = 20150417
+ pkgrel = 1
+ url = http://abc.sourceforge.net/abcMIDI/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = glibc
+ source = http://ifdo.pugmarks.com/~seymour/runabc/abcMIDI-2015-04-17.zip
+ sha256sums = 764a5ff1d0d6de5289156b76028b025d2f03b8d7bfaeb459c71b82b04cdb0682
+
+pkgname = abcmidi
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..b8fad7621db1
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,45 @@
+2015-04-24 Peter Sutton <foxxy@foxdogstudios.com>
+
+ * 20150424-1 :
+ New upstream release
+
+2015-02-18 Peter Sutton <foxxy@foxdogstudios.com>
+
+ * 20150218-1 :
+ Fixed pkgver
+
+2015-02-17 Peter Sutton <foxxy@foxdogstudios.com>
+
+ * 20141225-1 :
+ New upstream release
+
+2014-11-25 Christopher Arndt <chris@chrisarndt.de>
+
+ * 20141118-1 :
+ new upstream release
+
+2014-08-10 Christopher Arndt <chris@chrisarndt.de>
+
+ * 20140424-1 :
+ new upstream release
+
+2014-03-12 Christopher Arndt <chris@chrisarndt.de>
+
+ * 20140205-1 :
+ updated to new upstream release.
+ switched to sha256 checksum.
+ fixed 'license' tag.
+
+2013-12-28 Christopher Arndt <chris@chrisarndt.de>
+
+ * 20131225-1 :
+ updated to new upstream release.
+
+2013-11-29 Christopher Arndt <chris@chrisarndt.de>
+
+ * 20131126-1 :
+ updated to new upstream release.
+ added ChangeLog.
+ added missing 'package()' function to PKGBUILD.
+ added samples to documentation dir.
+ added programming docs to documentation dir.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..878fe42f7a62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: Christopher Arndt <chris@chrisarndt.de>
+# Contributor: Luis Pablo Gasparotto <lpgasparotto at gmail dot com>
+# Contributor: Phillip Fynan <pfynan@gmail.com>
+# Maintainer: Peter Sutton <foxxy@foxdogstudios.com>
+
+_pkgver_year=2015
+_pkgver_month=04
+_pkgver_day=17
+
+pkgname=abcmidi
+pkgver="${_pkgver_year}${_pkgver_month}${_pkgver_day}"
+pkgrel=1
+pkgdesc="A set of tools for converting ABC files to MIDI files and vice versa, as well as other small utilities"
+url="http://abc.sourceforge.net/abcMIDI/"
+license=('GPL')
+depends=('glibc')
+makedepends=('unzip')
+changelog=ChangeLog
+source=("http://ifdo.pugmarks.com/~seymour/runabc/abcMIDI-${_pkgver_year}-${_pkgver_month}-${_pkgver_day}.zip")
+arch=(i686 x86_64)
+sha256sums=('764a5ff1d0d6de5289156b76028b025d2f03b8d7bfaeb459c71b82b04cdb0682')
+
+build() {
+ cd $srcdir/abcmidi
+ make 'binaries=abc2midi midi2abc abc2abc mftext midicopy abcmatch'
+}
+
+package() {
+ cd $srcdir/abcmidi
+ mkdir -p $pkgdir/usr/bin
+ make prefix=$pkgdir/usr 'binaries=abc2midi midi2abc abc2abc mftext midicopy abcmatch' install
+ # install programming documentation to docdir
+ install -m 755 -d $pkgdir/usr/share/doc/$pkgname/programming
+ install -m 644 doc/programming/*.txt doc/programming/*.abc \
+ $pkgdir/usr/share/doc/$pkgname/programming
+ # install example ABC files to docdir
+ install -m 755 -d $pkgdir/usr/share/doc/$pkgname/samples
+ install -m 644 samples/*.abc $pkgdir/usr/share/doc/$pkgname/samples
+}
+