summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-05-23 19:16:23 +0200
committerChristopher Arndt2022-05-23 19:16:23 +0200
commit09326fe93fbece4a0ed646d2201775ffac895e47 (patch)
tree54fcc4346834839f23347cea4268263cf9d535c9
parentd77e7b8d9a7e0664ede8b082510f1f8bd6e2c6e3 (diff)
downloadaur-09326fe93fbece4a0ed646d2201775ffac895e47.tar.gz
Fix FULL RELRO and add 'glibc' to depends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 225922867978..52b755b5c2a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = abcpp
pkgdesc = A simple yet powerful preprocessor designed for, but not limited to, ABC music files
pkgver = 1.4.6
- pkgrel = 1
+ pkgrel = 2
url = http://abcplus.sourceforge.net
arch = i686
arch = x86_64
license = GPL
+ depends = glibc
source = https://sourceforge.net/projects/abcplus/files/abcpp/abcpp-1.4.6.tar.gz
sha256sums = 05a9a7f81b35aff8f1b03ad0c41539508812ec1e52d2f584a180d3c12e35edc1
diff --git a/PKGBUILD b/PKGBUILD
index 7edc1a854619..10d83d57aece 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,23 @@
pkgname=abcpp
pkgver=1.4.6
-pkgrel=1
+pkgrel=2
pkgdesc='A simple yet powerful preprocessor designed for, but not limited to, ABC music files'
url='http://abcplus.sourceforge.net'
license=(GPL)
-source=("https://sourceforge.net/projects/abcplus/files/$pkgname/$pkgname-$pkgver.tar.gz")
arch=(i686 x86_64)
+depends=(glibc)
+source=("https://sourceforge.net/projects/abcplus/files/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('05a9a7f81b35aff8f1b03ad0c41539508812ec1e52d2f584a180d3c12e35edc1')
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i \
+ -e 's|\$(CC) \$(CFLAGS)|$(CC) $(CFLAGS) $(LDFLAGS) -D VERSION="$(VERSION)"|' \
+ -e '/^CFLAGS/d' \
+ Makefile
+}
+
build() {
cd $pkgname-$pkgver
make