summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2022-11-03 12:34:23 +0000
committerChristopher Arndt2022-11-03 12:34:23 +0000
commitefddb8b34e7ce2b967dcfb49b2cf257992c06b19 (patch)
treeb3bca7ee2be3991d875c6d6f01514c55e97d2f2b
parent09326fe93fbece4a0ed646d2201775ffac895e47 (diff)
downloadaur-efddb8b34e7ce2b967dcfb49b2cf257992c06b19.tar.gz
feat: import package 'abcpp' from AUR (#141)
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD25
-rw-r--r--abcpp-makefile-cflags.patch23
4 files changed, 45 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52b755b5c2a7..582d17342107 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = abcpp
- pkgdesc = A simple yet powerful preprocessor designed for, but not limited to, ABC music files
+ pkgdesc = A preprocessor designed for, but not limited to, ABC music files
pkgver = 1.4.6
- pkgrel = 2
+ pkgrel = 3
url = http://abcplus.sourceforge.net
- arch = i686
+ arch = aarch64
arch = x86_64
- license = GPL
+ groups = abc
+ groups = pro-audio
+ license = GPL2
depends = glibc
source = https://sourceforge.net/projects/abcplus/files/abcpp/abcpp-1.4.6.tar.gz
+ source = abcpp-makefile-cflags.patch
sha256sums = 05a9a7f81b35aff8f1b03ad0c41539508812ec1e52d2f584a180d3c12e35edc1
+ sha256sums = 3e57b254946fe9b9b8d07e41f87fd445b0480ffa2c8461ea758de2901a9b67af
pkgname = abcpp
diff --git a/.gitignore b/.gitignore
index 22a1f08ecbac..57e7fd90984f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,4 @@
pkg/
src/
-abcpp-*.tar.gz
-abcpp-*.pkg.tar.xz
-abcpp-*.pkg.tar.zst
-abcpp-*.src.tar.gz
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 10d83d57aece..e7078f007c01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
-# Contributor: Robert Knauer <robert@privatdemail.net>
-# Contributor: Eric Forgeot http://anamnese.online.fr
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=abcpp
pkgver=1.4.6
-pkgrel=2
-pkgdesc='A simple yet powerful preprocessor designed for, but not limited to, ABC music files'
+pkgrel=3
+pkgdesc='A preprocessor designed for, but not limited to, ABC music files'
url='http://abcplus.sourceforge.net'
-license=(GPL)
-arch=(i686 x86_64)
+license=(GPL2)
+arch=(aarch64 x86_64)
depends=(glibc)
-source=("https://sourceforge.net/projects/abcplus/files/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('05a9a7f81b35aff8f1b03ad0c41539508812ec1e52d2f584a180d3c12e35edc1')
+groups=(abc pro-audio)
+source=("https://sourceforge.net/projects/abcplus/files/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'abcpp-makefile-cflags.patch')
+sha256sums=('05a9a7f81b35aff8f1b03ad0c41539508812ec1e52d2f584a180d3c12e35edc1'
+ '3e57b254946fe9b9b8d07e41f87fd445b0480ffa2c8461ea758de2901a9b67af')
prepare() {
cd $pkgname-$pkgver
- sed -i \
- -e 's|\$(CC) \$(CFLAGS)|$(CC) $(CFLAGS) $(LDFLAGS) -D VERSION="$(VERSION)"|' \
- -e '/^CFLAGS/d' \
- Makefile
+ patch -p1 -N -r - -i "$srcdir"/abcpp-makefile-cflags.patch
}
build() {
diff --git a/abcpp-makefile-cflags.patch b/abcpp-makefile-cflags.patch
new file mode 100644
index 000000000000..650fe3e983f1
--- /dev/null
+++ b/abcpp-makefile-cflags.patch
@@ -0,0 +1,23 @@
+diff -uNr abcpp-1.4.6.orig/Makefile abcpp-1.4.6/Makefile
+--- abcpp-1.4.6.orig/Makefile 2021-11-16 12:34:01.000000000 +0100
++++ abcpp-1.4.6/Makefile 2022-11-03 13:10:21.905115204 +0100
+@@ -5,16 +5,16 @@
+
+ ABCPP = abcpp
+ VERSION = 1.4.6
+-CC = gcc
++CC ?= gcc
+ # settings for Linux, djgpp or mingw32
+-CFLAGS = -O3 -Wall -D VERSION=\"$(VERSION)\"
++CFLAGS ?= -O3 -Wall
+ # to make a mingw executable using cygwin, use these CFLAGS:
+ # CFLAGS = -O3 -Wall -mno-cygwin -DWIN32
+
+ SOURCE = $(ABCPP).c
+
+ $(ABCPP): $(SOURCE)
+- $(CC) $(CFLAGS) -o $(ABCPP) $(SOURCE)
++ $(CC) $(CFLAGS) $(LDFLAGS) -DVERSION=\"$(VERSION)\" -o $(ABCPP) $(SOURCE)
+
+ tgz: $(ABCPP)
+ ln -s . $(ABCPP)-$(VERSION); \