summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-06-20 19:53:16 +0200
committerGrey Christoforo2015-06-20 19:53:16 +0200
commite538ffbf1a9d927ac8cd4ce073a5be45e89d1ed5 (patch)
tree1db72db3b5c1a17a1ab9035e670a306473dd632a
downloadaur-e538ffbf1a9d927ac8cd4ce073a5be45e89d1ed5.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
-rw-r--r--abgx360.install10
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0af5d3b0c1f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = abgx360
+ pkgdesc = An app for checking Xbox 360 ISOs
+ pkgver = 1.0.6
+ pkgrel = 2
+ url = http://abgx360.xecuter.com/
+ install = abgx360.install
+ arch = x86_64
+ arch = i686
+ license = unknown
+ depends = zlib
+ depends = curl
+ optdepends = abgx360gui: a GUI for this tool
+ source = http://abgx360.xecuter.com/dl/abgx360-1.0.6.tar.gz
+ md5sums = 04b0c9e0461faa92ca5f8fac78bafe57
+
+pkgname = abgx360
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df3de73f7d16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=abgx360
+pkgver=1.0.6
+pkgrel=2
+pkgdesc="An app for checking Xbox 360 ISOs"
+url="http://abgx360.xecuter.com/"
+arch=('x86_64' 'i686')
+license=('unknown')
+depends=('zlib' 'curl')
+optdepends=('abgx360gui: a GUI for this tool')
+source=("http://abgx360.xecuter.com/dl/${pkgname}-${pkgver}.tar.gz")
+md5sums=('04b0c9e0461faa92ca5f8fac78bafe57')
+install=abgx360.install
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # abgx360.net is somehow no longer working, so we'll switch to abgx360.xecuter.com for now
+ sed -i 's/abgx360.net/abgx360.xecuter.com/g' src/abgx360.c
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ #./autogen.sh
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abgx360.install b/abgx360.install
new file mode 100644
index 000000000000..d6f5a48eedca
--- /dev/null
+++ b/abgx360.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo
+ echo "The first time abgx360 is run it will create an empty folder:"
+ echo "~/.abgx360/StealthFiles"
+ echo "Is is recommended that you search the interent for the file"
+ echo "abgx360_video_waves_1-19.7z"
+ echo "and extract the condents of that archive into your StealthFiles directory."
+ echo
+}
+