summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWayne Hartmann2016-11-28 05:24:34 -0600
committerWayne Hartmann2016-11-28 05:24:34 -0600
commit483700d504afc076071369c720b2447dcf5db6fa (patch)
treed581e2c287a2740079ae6fdc9a26f95faa097a2e
downloadaur-483700d504afc076071369c720b2447dcf5db6fa.tar.gz
Initial Commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD35
-rw-r--r--abgx360gui.desktop11
-rw-r--r--abgx360gui.pngbin0 -> 244 bytes
-rw-r--r--abgx360gui_TopBitmap_XPM.xpm.patch24
5 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bee7c8537987
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Nov 28 11:23:44 UTC 2016
+pkgbase = abgx360gui
+ pkgdesc = A GTK frontend for abgx360
+ pkgver = 1.0.2
+ pkgrel = 3
+ url = http://abgx360.xecuter.com/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = abgx360
+ depends = wxgtk2.8
+ depends = xterm
+ source = http://dl.dropbox.com/u/59058148/abgx360gui-1.0.2.tar.gz
+ source = abgx360gui.desktop
+ source = abgx360gui.png
+ source = abgx360gui_TopBitmap_XPM.xpm.patch
+ sha256sums = 949fdcb871d038b1c8aed658e3d3d0fe6c44c73fbea8defc46ce37b0abf91303
+ sha256sums = 2449af1ef890cf9043971c35576f553c9b6d4f62c08126a70b449dca4d4d5fa0
+ sha256sums = 074bbc00f247042c6ad1c01a02a3f25178572732eae09309aa4078741b1c2aa3
+ sha256sums = afa5c5c344d4bf9e2d6ff307b8e62aa2734543352cd76140467ad53c0378197a
+
+pkgname = abgx360gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9c23e33361f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Wayne Hartmann <wayne@bitstorm.pw>
+# Contributor: Tetsumaki <http://goo.gl/YMBdA>
+
+pkgname=abgx360gui
+pkgver=1.0.2
+pkgrel=3
+pkgdesc="A GTK frontend for abgx360"
+arch=('i686' 'x86_64')
+license=('unknown')
+url="http://abgx360.xecuter.com/"
+depends=('abgx360' 'wxgtk2.8' 'xterm')
+source=(http://dl.dropbox.com/u/59058148/${pkgname}-${pkgver}.tar.gz
+ abgx360gui.desktop
+ abgx360gui.png
+ abgx360gui_TopBitmap_XPM.xpm.patch)
+sha256sums=('949fdcb871d038b1c8aed658e3d3d0fe6c44c73fbea8defc46ce37b0abf91303'
+ '2449af1ef890cf9043971c35576f553c9b6d4f62c08126a70b449dca4d4d5fa0'
+ '074bbc00f247042c6ad1c01a02a3f25178572732eae09309aa4078741b1c2aa3'
+ 'afa5c5c344d4bf9e2d6ff307b8e62aa2734543352cd76140467ad53c0378197a')
+
+build() {
+ patch "${srcdir}/${pkgname}-${pkgver}/src/Images/abgx360gui_TopBitmap_XPM.xpm" "${srcdir}/abgx360gui_TopBitmap_XPM.xpm.patch"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i 's/http\:\/\/abgx360.net/http\:\/\/abgx360.xecuter.com/g' src/abgx360gui.cpp
+ ./configure --prefix=/usr --with-wx-config=/usr/bin/wx-config-2.8
+ make
+}
+
+package () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -d ${pkgdir}/usr/share/{applications,pixmaps}
+ install -m 644 ${startdir}/abgx360gui.desktop ${pkgdir}/usr/share/applications/
+ install -m 644 ${startdir}/abgx360gui.png ${pkgdir}/usr/share/pixmaps/
+}
diff --git a/abgx360gui.desktop b/abgx360gui.desktop
new file mode 100644
index 000000000000..807909147034
--- /dev/null
+++ b/abgx360gui.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Abgx360 GUI
+Comment=A program for checking if your xbox backups are valid
+Comment[fr]=Un programme pour vérifier si vos backups sont valides
+Exec=abgx360gui
+Icon=abgx360gui
+Terminal=false
+Type=Application
+Categories=Utility;Games
+StartupNotify=true
diff --git a/abgx360gui.png b/abgx360gui.png
new file mode 100644
index 000000000000..13cba18be261
--- /dev/null
+++ b/abgx360gui.png
Binary files differ
diff --git a/abgx360gui_TopBitmap_XPM.xpm.patch b/abgx360gui_TopBitmap_XPM.xpm.patch
new file mode 100644
index 000000000000..e6a787bf47b9
--- /dev/null
+++ b/abgx360gui_TopBitmap_XPM.xpm.patch
@@ -0,0 +1,24 @@
+58,68c58,68
+< "000000000000000000000000000000000000000000000000000000000000000000000000022222222222222222222222200000000222222222222222222222222000000002222222222222222222222220000000000000000000000000000000000000000000000000005500000000000000550000005500000000000000550000005500000000000000550000000000000222200220022000222200000000000000000000000000000000000000000000000000222200222000000000000000000000000000000000000000000000000000000000000022200000000000000000000002222000002220000222220000000000000000000000000000000000002222000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "000000000000000000000000000000000000000000000000000000000000000000000000022222222222222222222222200000000222222222222222222222222000000002222222222222222222222220000000000000000000000000000000000000000000000000005500000000000000550000005500000000000000550000005500000000000000550000000000002200220220022000022000000000000000000000000000000000000000000000000000220000022000000020000000200000000000000000000000000020000000200000000002200000000000000000000022002200022000002200022000000000000000000000000000200000000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "000000000000000000000000000000000000000000000000000000000000000000000000022222222222222222222222200000000222222222222222222222222000000002222222222222222222222220000000000000000000000000000000000000000000000000005500000000000000550000005500000000000000550000005500000000000000550000000000022000220220022000022000000000000000000000000000000000000000000000000000220000022000000220000002200000000000000022200000000220000002200000000002200000000000000000000000002200220000002200222000000000000000000000000002200000000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "000000000000000000000000000000000000000000000000000000000000000000000000022222222222222222222222200000000222222222222222222222222000000002222222222222222222222220000000000000000000000000000000000000000000000000005500000000000000550000005500000000000000550000005500000000000000550000000000022000000220022000022000000000000000000000000000000000000000000000000000220000022022002222220022222200220222000022200000002200000022000222200002222200022202202200022000002200220000002202222000000000222220000222200022222200000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "111111111111111111111111111111111111111111111111111111111111111111111111122222222222222222222222211111111222222222222222222222222111111112222222222222222222222221111111111111111111111111111111111111111111111110005555555555555555550000005555555555555555550000005555555555555555550001111111122000000220022000022001111111111111111111111111111111111111111111111100220000022202200220000002200000022002200000000000022000000220000000220002200220220022000220220000222000222220002202022000000000220022002200220002200000000022001111111111111111111111111111111111111111111111111111111111111111111111111111111111",
+< "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000022002220220022000022000000000000000000000000000000000000000000000000000220000022002200220000002200000022002200000000000220000002200000222220002200220220022000022200000002200220022002222022000000000220022002222220002200000000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000022000220220022000022000000000000000000000000000000000000000000000000000220000022002200220000002200000022002200022200002200000022000002200220002200220220022000022200000002200220022002220022000000000220022002200000002200000000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000002200220220022000022000000000000000000000000000000000000000000000000000220000022002200220220002202200022002200022200022000000220000002200220002200220022222000220220022002200220022002200022000222000220022002200220002202200000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222220022220000222200000000000000000000000000000000000000000000000000222200222002200022200000222000022222000000000020000000200000000222022022022200000022002200022002222000022220000222220000222000220022000222200000222000002222000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000022000000000000000000000000000000000000000000000220022000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+< "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222200000000000000000000000000000000000000000000022220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+---
+> "000000000000000000000000000000000000000000000000000000000000000000000000022222222222222222222222200000000222222222222222222222222000000002222222222222222222222220000000000000000000000000000000000000000000000000005500000000000000550000005500000000000000550000005500000000000000550000000000000222200220022000222200000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "000000000000000000000000000000000000000000000000000000000000000000000000022222222222222222222222200000000222222222222222222222222000000002222222222222222222222220000000000000000000000000000000000000000000000000005500000000000000550000005500000000000000550000005500000000000000550000000000002200220220022000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "000000000000000000000000000000000000000000000000000000000000000000000000022222222222222222222222200000000222222222222222222222222000000002222222222222222222222220000000000000000000000000000000000000000000000000005500000000000000550000005500000000000000550000005500000000000000550000000000022000220220022000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "000000000000000000000000000000000000000000000000000000000000000000000000022222222222222222222222200000000222222222222222222222222000000002222222222222222222222220000000000000000000000000000000000000000000000000005500000000000000550000005500000000000000550000005500000000000000550000000000022000000220022000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "111111111111111111111111111111111111111111111111111111111111111111111111122222222222222222222222211111111222222222222222222222222111111112222222222222222222222221111111111111111111111111111111111111111111111110005555555555555555550000005555555555555555550000005555555555555555550001111111122000000220022000022001111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111",
+> "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000022002220220022000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000022000220220022000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000002200220220022000022000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222220022220000222200000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",
+> "000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000222222220000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000",