summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilo Brueckner2017-04-16 11:14:34 +0200
committerTilo Brueckner2017-04-16 11:14:34 +0200
commita29a555fe200a5b4a3f8c5586181f5f1a55c21fe (patch)
treed5e83e8fcde2a9dd59f310c2c01c2723b2a63f8d
downloadaur-abiocard.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
-rw-r--r--hardware.patch13
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83c17ebc55a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.0.1
+# Sun Apr 2 14:29:40 UTC 2017
+pkgbase = abiocard
+ pkgdesc = programs for abiocard
+ pkgver = 2015_02_28
+ pkgrel = 2
+ url = https://www.axiris.eu/en/index.php/i-o-cards/abiocard/documents-and-software
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ source = https://www.axiris.eu/download/abiocard/sw_2015_02_28/abiocard.tar.gz
+ source = hardware.patch
+ sha256sums = a6bf6fdadbcd926c2bc88c41439094547de9a7e6675c51ad7935ca4d63c3b2ee
+ sha256sums = c90a334f2dd503d4d1862f297336863c9b9ac0b340043755a9fc4b2f58628d86
+
+pkgname = abiocard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..248f06809b14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: BluePeril <blueperil (at) blueperil _dot_ de>
+
+pkgname=abiocard
+pkgver=2015_02_28
+pkgrel=2
+pkgdesc='programs for abiocard'
+arch=('armv6h' 'armv7h')
+url='https://www.axiris.eu/en/index.php/i-o-cards/abiocard/documents-and-software'
+license=('GPL')
+source=("https://www.axiris.eu/download/abiocard/sw_$pkgver/abiocard.tar.gz"
+ 'hardware.patch')
+sha256sums=('a6bf6fdadbcd926c2bc88c41439094547de9a7e6675c51ad7935ca4d63c3b2ee'
+ 'c90a334f2dd503d4d1862f297336863c9b9ac0b340043755a9fc4b2f58628d86')
+
+prepare() {
+ cd "${srcdir}/${pkgname}/"
+
+ patch -p0 -i "${srcdir}/hardware.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}/"
+
+ cp common/arm-linux-gnueabihf/platform.h common/platform.h
+ cd abiocard
+
+ make -f abiocardserver.mk clean
+ make -f abiocardtime.mk clean
+
+ make -f abiocardserver.mk
+ make -f abiocardtime.mk
+}
+
+package(){
+ cd "${srcdir}/${pkgname}/abiocard"
+
+ install -Dm755 abiocardserver ${pkgdir}/usr/bin/abiocardserver
+ install -Dm755 abiocardtime ${pkgdir}/usr/bin/abiocardtime
+}
diff --git a/hardware.patch b/hardware.patch
new file mode 100644
index 000000000000..d16bb4d17b47
--- /dev/null
+++ b/hardware.patch
@@ -0,0 +1,13 @@
+--- common/rpidetect.c_old 2017-04-02 15:18:48.426790651 +0200
++++ common/rpidetect.c 2017-04-02 15:19:04.359850781 +0200
+@@ -42,8 +42,8 @@
+
+ static const CHAR match_hw_asciiz[] = { "Hardware\t: " };
+ static const CHAR match_rev_asciiz[] = { "Revision\t: " };
+-static const CHAR match_bcm2708_asciiz[] = { "BCM2708" };
+-static const CHAR match_bcm2709_asciiz[] = { "BCM2709" };
++static const CHAR match_bcm2708_asciiz[] = { "BCM2835" };
++static const CHAR match_bcm2709_asciiz[] = { "BCM2836" };
+
+
+ // The read buffer is filled with chunk of data read from cpuinfo. The buffer is