summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick McCarty2019-02-06 20:41:06 -0800
committerPatrick McCarty2019-02-06 20:41:06 -0800
commit6e04151aad3c5a42afdfa6d01630c48256c23ae3 (patch)
treed06fe3274a1f9d3b982e621ecab7a1f864594dce
parent6a3db54910698863c6a1f071a04871e2d542f904 (diff)
downloadaur-6e04151aad3c5a42afdfa6d01630c48256c23ae3.tar.gz
bump to 1.0.6
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--use-unzip-for-eopkg.patch89
3 files changed, 8 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0e87375ea3b..319f3ab4267a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Dec 11 02:35:08 UTC 2017
pkgbase = abireport
pkgdesc = Tool to create ABI reports from ELF binaries in packaging
- pkgver = 1.0.5
- pkgrel = 2
+ pkgver = 1.0.6
+ pkgrel = 1
url = https://github.com/clearlinux/abireport
arch = i686
arch = x86_64
@@ -12,10 +10,8 @@ pkgbase = abireport
optdepends = rpm-org: extract rpm files
optdepends = dpkg: extract deb files
optdepends = unzip: extract eopkg files
- source = https://github.com/clearlinux/abireport/releases/download/v1.0.5/abireport-1.0.5.tar.gz
- source = use-unzip-for-eopkg.patch
- sha256sums = a0b6fa0a5b160e3a40937e7e636729aaf55a033986f8c3abe59742d83216e162
- sha256sums = 5a9930baeb8b850f116b13f8d86a852d0bfd12d642d81f85f69f27e353f0fab9
+ source = https://github.com/clearlinux/abireport/releases/download/v1.0.6/abireport-1.0.6.tar.gz
+ sha256sums = 60beb805335302f999c32bda62f56afd6971f27499580fece84fe4d6bb9cb653
pkgname = abireport
diff --git a/PKGBUILD b/PKGBUILD
index c0cb6974b976..f0efdc413820 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Patrick McCarty <pnorcks at gmail dot com>
pkgname=abireport
-pkgver=1.0.5
-pkgrel=2
+pkgver=1.0.6
+pkgrel=1
pkgdesc="Tool to create ABI reports from ELF binaries in packaging"
arch=('i686' 'x86_64')
url="https://github.com/clearlinux/abireport"
@@ -11,15 +11,8 @@ makedepends=('go')
optdepends=('rpm-org: extract rpm files'
'dpkg: extract deb files'
'unzip: extract eopkg files')
-source=("https://github.com/clearlinux/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
- "use-unzip-for-eopkg.patch")
-sha256sums=('a0b6fa0a5b160e3a40937e7e636729aaf55a033986f8c3abe59742d83216e162'
- '5a9930baeb8b850f116b13f8d86a852d0bfd12d642d81f85f69f27e353f0fab9')
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/use-unzip-for-eopkg.patch"
-}
+source=("https://github.com/clearlinux/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('60beb805335302f999c32bda62f56afd6971f27499580fece84fe4d6bb9cb653')
build() {
cd "$pkgname-$pkgver"
diff --git a/use-unzip-for-eopkg.patch b/use-unzip-for-eopkg.patch
deleted file mode 100644
index 592c3504b760..000000000000
--- a/use-unzip-for-eopkg.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From cfa7b0ad93b5c848ade2beb89ba1b60c597a9a8b Mon Sep 17 00:00:00 2001
-From: Ikey Doherty <ikey@solus-project.com>
-Date: Wed, 22 Nov 2017 19:12:26 +0000
-Subject: [PATCH] explode/eopkg: Use a portable function to explode the eopkg
-
-This function is much like the RPM explosion helper, by using a simple
-pipe to get directly to the contents of the package. Here we simply
-pipe unzip to tar xf, explicitly passing the `install.tar.xz` payload
-to tar. Internally an eopkg is simply a ZIP file with a tarball payload
-and some XML data, so this is always going to work.
-
-Signed-off-by: Ikey Doherty <ikey@solus-project.com>
----
- src/explode/eopkg.go | 39 ++++++++++++++++++++++++++++++---------
- 1 file changed, 30 insertions(+), 9 deletions(-)
-
-diff --git a/src/explode/eopkg.go b/src/explode/eopkg.go
-index cea004d..2ecdca5 100644
---- a/src/explode/eopkg.go
-+++ b/src/explode/eopkg.go
-@@ -17,20 +17,21 @@
- package explode
-
- import (
-+ "io"
- "io/ioutil"
-- "os"
- "os/exec"
- "path/filepath"
- "strings"
- )
-
--// Eopkg will explode all .eopkg's specified and then return
--// the install/ path inside that exploded tree.
-+// Eopkg will explode all eopkgs passed to it and return the path to
-+// the "root" to walk.
- func Eopkg(pkgs []string) (string, error) {
- rootDir, err := ioutil.TempDir("", "abireport-eopkg")
- if err != nil {
- return "", err
- }
-+
- // Ensure cleanup happens
- OutputDir = rootDir
-
-@@ -43,17 +44,37 @@ func Eopkg(pkgs []string) (string, error) {
- if strings.HasSuffix(archive, ".delta.eopkg") {
- continue
- }
-- eopkg := exec.Command("uneopkg", []string{
-+
-+ eopkg := exec.Command("unzip", []string{
-+ "-p",
- fp,
-+ "install.tar.xz",
-+ }...)
-+ tar := exec.Command("tar", []string{
-+ "-xJf",
-+ "-",
- }...)
-- eopkg.Stdout = nil
-- eopkg.Stderr = os.Stderr
-- eopkg.Dir = rootDir
-+ // Pipe eopkg into tar
-+ r, w := io.Pipe()
-+ defer r.Close()
-+ eopkg.Stdout = w
-+ tar.Stdin = r
-+ tar.Stdout = nil
-+ tar.Stderr = nil
-+ tar.Dir = rootDir
-
-- if err = eopkg.Run(); err != nil {
-+ eopkg.Start()
-+ tar.Start()
-+ go func() {
-+ defer w.Close()
-+ eopkg.Wait()
-+ }()
-+ if err := tar.Wait(); err != nil {
-+ r.Close()
- return "", err
- }
-+ r.Close()
- }
-
-- return filepath.Join(rootDir, "install"), nil
-+ return rootDir, nil
- }