summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-08-14 18:17:29 +0100
committerWorMzy Tykashi2018-08-14 18:17:29 +0100
commit16e8c95ea03222a57e40d805ffe0f9878a678171 (patch)
treeedc8713136e625a1bc4ff4d6e8a40ad1de2aa919
parenta355e59ffde193b57e8446052d2e0f169f282434 (diff)
downloadaur-16e8c95ea03222a57e40d805ffe0f9878a678171.tar.gz
Fix enchant-2 detection, explicitly enable spellchecker
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--enchant-2.patch (renamed from enchant-2.1.patch)12
3 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 441d1358f00d..8a6c23506fe4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = abiword-gtk2
pkgdesc = Fully-featured word processor, GTk2, No plugins, Lite version
pkgver = 3.0.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.abisource.com
arch = i686
arch = x86_64
@@ -18,9 +18,9 @@ pkgbase = abiword-gtk2
conflicts = abiword
conflicts = abiword-plugins
source = abiword-3.0.2.tar.gz::http://abisource.com/downloads/abiword/3.0.2/source/abiword-3.0.2.tar.gz
- source = enchant-2.1.patch
+ source = enchant-2.patch
sha256sums = afbfd458fd02989d8b0c6362ba8a4c14686d89666f54cfdb5501bd2090cf3522
- sha256sums = 444dc2aadea3c80310a509b690097541573f6d2652c573d04da66a0f385fcfb2
+ sha256sums = f510f4df2cf597f5493f52ce855b4209628d7622b03532c2ef221f8b7032a349
pkgname = abiword-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index 4ac90d4ba6cc..916e67538a33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=abiword-gtk2
_pkgname=abiword
pkgver=3.0.2
-pkgrel=2
+pkgrel=3
pkgdesc='Fully-featured word processor, GTk2, No plugins, Lite version'
arch=('i686' 'x86_64')
license=('GPL')
@@ -13,15 +13,15 @@ makedepends=('pkgconfig' 'boost')
conflicts=('abiword' 'abiword-plugins')
url='http://www.abisource.com'
source=("$_pkgname-$pkgver.tar.gz::http://abisource.com/downloads/$_pkgname/$pkgver/source/$_pkgname-$pkgver.tar.gz"
- enchant-2.1.patch)
+ enchant-2.patch)
sha256sums=('afbfd458fd02989d8b0c6362ba8a4c14686d89666f54cfdb5501bd2090cf3522'
- '444dc2aadea3c80310a509b690097541573f6d2652c573d04da66a0f385fcfb2')
+ 'f510f4df2cf597f5493f52ce855b4209628d7622b03532c2ef221f8b7032a349')
prepare() {
cd $_pkgname-$pkgver
# Replace deprecated enchant functions
- patch -Np1 -i ../enchant-2.1.patch
+ patch -Np1 -i ../enchant-2.patch
}
build() {
@@ -33,6 +33,7 @@ build() {
--with-gtk2 \
--enable-clipart \
--enable-templates \
+ --enable-spell \
--without-redland \
--without-libical \
--disable-builtin-plugins \
diff --git a/enchant-2.1.patch b/enchant-2.patch
index 010aac100908..f1d653a8c562 100644
--- a/enchant-2.1.patch
+++ b/enchant-2.patch
@@ -27,3 +27,15 @@
}
void EnchantChecker::ignoreWord (const UT_UCSChar *toCorrect, size_t toCorrectLen)
+
+--- abiword-3.0.2/configure 2018-08-14 17:58:49.176036155 +0100
++++ abiword-3.0.2/configure 2018-08-14 17:57:54.396998207 +0100
+@@ -4197,7 +4197,7 @@
+ "
+
+ # optional deps
+-enchant_req='enchant >= 1.2.0'
++enchant_req='enchant-2 >= 1.2.0'
+ gio_req='gio-2.0'
+ goffice_req='libgoffice-0.10 >= 0.10.0'
+