summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2021-06-05 00:36:05 -0700
committerSean Greenslade2021-06-05 00:36:05 -0700
commit8af013d96db4746d2e15b7473924f5dbe26b8704 (patch)
tree2c9e624a6599c9e07e27b71d530b3034280f8dd1
parentc7f25bbad87adf86c40e07eb28f2b5f02422294a (diff)
downloadaur-8af013d96db4746d2e15b7473924f5dbe26b8704.tar.gz
Fix compilation CXX target and add optdep for spellcheck.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d34413a55ae7..5af0b42733a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = abiword-gtk2
pkgdesc = Fully-featured word processor, GTk2, No plugins, Lite version
pkgver = 3.0.4
- pkgrel = 2
+ pkgrel = 3
url = https://www.abisource.com
arch = i686
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = abiword-gtk2
depends = desktop-file-utils
depends = gtk2
depends = libxslt
+ optdepends = hunspell: for spell checking
conflicts = abiword
conflicts = abiword-plugins
source = abiword-3.0.4.tar.gz::https://abisource.com/downloads/abiword/3.0.4/source/abiword-3.0.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 5eefdc015153..f1771465b1b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
-# Contributor: zootboy
+# Maintainer: Sean Greenslade <aur@seangreenslade.com>
+# Contributor: WorMzy Tykashi <wormzy.tykashi@gmail.com>
# Contributor: FadeMind <fademind@gmail.com>
# Contributor: Richard Jackson <rj@iinet.net.au>
pkgname=abiword-gtk2
_pkgname=abiword
pkgver=3.0.4
-pkgrel=2
+pkgrel=3
pkgdesc='Fully-featured word processor, GTk2, No plugins, Lite version'
arch=('i686' 'x86_64')
license=('GPL')
depends=('fribidi' 'wv' 'librsvg' 'enchant' 'desktop-file-utils' 'gtk2' 'libxslt')
makedepends=('boost')
+optdepends=('hunspell: for spell checking')
conflicts=('abiword' 'abiword-plugins')
url='https://www.abisource.com'
source=("$_pkgname-$pkgver.tar.gz::https://abisource.com/downloads/$_pkgname/$pkgver/source/$_pkgname-$pkgver.tar.gz"
@@ -33,6 +34,8 @@ prepare() {
build() {
cd $_pkgname-$pkgver
+ CXXFLAGS="-std=c++14"
+
./configure --prefix=/usr \
--enable-shared \
--disable-static \