summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorajs1242015-06-09 20:57:09 +0200
committerajs1242015-06-09 20:57:09 +0200
commit37207d85402bdf0d29f7dbf6298891f2287566c7 (patch)
tree8aa677096d7e6f1b0608d19f9d4763d319103b00
downloadaur-37207d85402bdf0d29f7dbf6298891f2287566c7.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..587767c29ffa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = abootimg-git
+ pkgdesc = A tool to read/write/update android boot images
+ pkgver = 0.6.r6.g1ebeb39
+ pkgrel = 1
+ url = http://gitorious.org/ac100/abootimg
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ license = GPL
+ makedepends = git
+ depends = util-linux
+ depends = cpio
+ provides = abootimg
+ source = git+https://gitlab.com/ajs124/abootimg.git
+ sha256sums = SKIP
+
+pkgname = abootimg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc8cc37f13f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: ajs124 < aur AT ajs124 DOT de >
+# Contributor: Benoit Favre <benoit.favre@gmail.com>
+# Contributor: Thomas Hebb <tommyhebb@gmail.com>
+
+pkgname=abootimg-git
+pkgver=0.6.r6.g1ebeb39
+pkgrel=1
+pkgdesc="A tool to read/write/update android boot images"
+arch=('i686' 'x86_64' 'arm' 'armv7h')
+url="http://gitorious.org/ac100/abootimg"
+license=('GPL')
+depends=('util-linux' 'cpio')
+makedepends=('git')
+provides=('abootimg')
+# upstream seems dead and gitorious is about to shut down -> use my mirror
+#source=('git+https://gitorious.org/ac100/abootimg.git')
+source=('git+https://gitlab.com/ajs124/abootimg.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "abootimg"
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/abootimg"
+
+ make
+ gzip -f debian/abootimg.1
+}
+
+package() {
+ cd "${srcdir}/abootimg"
+
+ install -d "${pkgdir}/usr/bin" "${pkgdir}/usr/share/man/man1/"
+ install -t "${pkgdir}/usr/bin" abootimg abootimg-pack-initrd abootimg-unpack-initrd
+ install -t "${pkgdir}/usr/share/man/man1/" debian/abootimg.1.gz
+}