aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoxie Gibson2021-08-13 13:50:09 +0100
committerRoxie Gibson2021-08-13 13:50:09 +0100
commit3825433323bb5112dbd86f06cb03aef072b06aa9 (patch)
tree684887dee86e41349577607c591f357b0b4e5b12
parent0cf865e91474f3a935278c6e52f6693b53455c55 (diff)
downloadaur-3825433323bb5112dbd86f06cb03aef072b06aa9.tar.gz
Updated readme
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD2
-rw-r--r--README.md28
4 files changed, 32 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ae5dcc3df1c..0093568488dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = abra-git
pkgdesc = The Co-op Cloud command-line interface 🎩🐇
- pkgver = r181.edd0b1e
+ pkgver = r191.cc9c690
pkgrel = 1
url = https://git.coopcloud.tech/coop-cloud/go-abra
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 191f5ee6b0da..3d61abe8691e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
pkg
src
-go-abra \ No newline at end of file
+go-abra
+*.tar* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d1b56ded82d6..4482a15b1d08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Roxie Gibson <me@roxanne.dev>
pkgname=abra-git
-pkgver=r181.edd0b1e
+pkgver=r191.cc9c690
pkgrel=1
pkgdesc="The Co-op Cloud command-line interface 🎩🐇"
arch=("x86_64" "i686" "aarch64")
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..b44a83615156
--- /dev/null
+++ b/README.md
@@ -0,0 +1,28 @@
+# abra-aur
+
+This is the aur install repo.
+
+## How to publish to AUR
+
+### Step 0 - Setup: Done once
+
+- Create new ssh key and ssh config for the aur as described in the [arch wiki](https://wiki.archlinux.org/title/AUR_submission_guidelines#Authentication)
+- Make account at <https://aur.archlinux.org> and add the ssh public key for the aur
+- Ask Roxie to add your account as a maintainer
+- Make sure you are listed as a maintainer in the top comments of the `PKGBUILD` file.
+- This repo should have two remotes, this remote and `ssh://aur@aur.archlinux.org/abra-git.git`.
+
+### Step 1 - Changes and testing
+
+- Make required changes to `PKGBUILD`. In this repo, we are just running the git repo so there is no reason to version bump. If you run `makepkg` it will edit `PKGBUILD` for you and bump it. If this is all you are doing and need to commit that bump, continue to step 2.
+- Use Arch based system (VM if you don't have one at home) with the base-devel package.
+- run `makepkg -i` to build the package and install it to the system
+- test it works as intended
+
+### Step 2 - Pushing the changes
+
+- run `makepkg --printsrcinfo > .SRCINFO`
+- commit changes to the git repo
+- Push commit to origin
+- Push commit to aur with `git push aur main:master` (This will push the main branch to master, read more [here](https://bbs.archlinux.org/viewtopic.php?id=257186). it even has the quote "And, I resist attempts to pare down language. 1984 was meant as a warning, not a guide." if you wanna yikes today at some shitty tech bros)
+- If all has gone well, this will push your changes to the aur and they will be accessable using an aur helper like `yay`