summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Seifferth2022-05-22 17:37:10 +0200
committerFrank Seifferth2022-05-22 17:38:07 +0200
commit053e91adf2f9ce404bb89a825a93629ab19210cf (patch)
tree28ec031d62c2931cc99afdd7583a47f61e68fd1b
parentf4f80210fb0261634ebac38d1fd8f439b47778e6 (diff)
downloadaur-053e91adf2f9ce404bb89a825a93629ab19210cf.tar.gz
Update to v1.1.2
This commit includes adjustments to the makedepends and to the commands used to build the package.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43842f5864ab..4f606ab89328 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = abricotine
pkgdesc = A markdown editor with inline preview
- pkgver = 1.0.0
- pkgrel = 2
+ pkgver = 1.1.2
+ pkgrel = 1
url = http://abricotine.brrd.fr
arch = x86_64
license = GPL3
makedepends = npm
- makedepends = nodejs-lts-erbium
- makedepends = python2
+ makedepends = nodejs
+ makedepends = libxcrypt-compat
+ makedepends = rpm-tools
+ makedepends = dpkg
depends = libxss
- source = abricotine-1.0.0.tar.gz::https://github.com/brrd/abricotine/archive/1.0.0.tar.gz
+ source = abricotine-1.1.2.tar.gz::https://github.com/brrd/abricotine/archive/1.1.2.tar.gz
source = abricotine.desktop
- sha256sums = ed12ba3d518b87bbd965b09a25c931d827c2250deb6af0d6c5137ff3795a0575
+ sha256sums = d821d767535d859ff0334f2d17b87f3398a073d86387cc8ff39766f5d49fc358
sha256sums = 164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c
pkgname = abricotine
-
diff --git a/PKGBUILD b/PKGBUILD
index 750a8897293a..1a04523db827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,31 @@
# Contributor: Maxim Andersson <thesilentboatman@gmail.com>
pkgname=abricotine
-pkgver=1.0.0
-pkgrel=2
+pkgver=1.1.2
+pkgrel=1
pkgdesc="A markdown editor with inline preview"
arch=('x86_64')
url="http://abricotine.brrd.fr"
license=('GPL3')
depends=('libxss')
-makedepends=('npm' 'nodejs-lts-erbium' 'python2')
+makedepends=('npm' 'nodejs' 'libxcrypt-compat' 'rpm-tools' 'dpkg')
source=("abricotine-${pkgver}.tar.gz::https://github.com/brrd/abricotine/archive/${pkgver}.tar.gz"
"abricotine.desktop")
-sha256sums=('ed12ba3d518b87bbd965b09a25c931d827c2250deb6af0d6c5137ff3795a0575'
+sha256sums=('d821d767535d859ff0334f2d17b87f3398a073d86387cc8ff39766f5d49fc358'
'164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c')
build() {
cd "${srcdir}/abricotine-${pkgver}"
npm install --cache ../cache --devdir="${srcdir}/devdir"
- npm run packager
+ npm run dist --cache ../cache --devdir="${srcdir}/devdir"
}
package() {
cd "${srcdir}/abricotine-${pkgver}"
install -d "${pkgdir}/opt/abricotine"
- cp -r dist/*/* "${pkgdir}/opt/abricotine"
+ cp -r dist/linux-unpacked/* "${pkgdir}/opt/abricotine"
install -d "${pkgdir}/usr/bin"
ln -s "/opt/abricotine/abricotine" "${pkgdir}/usr/bin/abricotine"