summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-04-15 23:27:29 +0000
committerxiota2024-04-15 23:29:40 +0000
commit6b1f6f0c86db6fd6a3d7d27e2369db0a9ad60787 (patch)
treea07742b356671d77c1ac663b9cc83aadb0eef327
parent2ca97c313d760a64b627c547effcdcaaa8c37c04 (diff)
downloadaur-6b1f6f0c86db6fd6a3d7d27e2369db0a9ad60787.tar.gz
add discontinued notice
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD76
-rw-r--r--abricotine.install36
-rw-r--r--abricotine.sh36
5 files changed, 145 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30b3af1ed531..c8517430b364 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = abricotine
- pkgdesc = A markdown editor with inline preview
+ pkgdesc = A markdown editor with inline preview (discontinued)
pkgver = 1.1.4
- pkgrel = 1
- url = http://abricotine.brrd.fr
+ pkgrel = 2
+ url = https://github.com/brrd/Abricotine/issues/347
+ install = abricotine.install
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
makedepends = npm
makedepends = nodejs
+ depends = libnotify
depends = libxss
source = abricotine-1.1.4.tar.gz::https://github.com/brrd/abricotine/archive/1.1.4.tar.gz
source = abricotine.desktop
+ source = abricotine.sh
sha256sums = 1c1fd67770a75e3fc8cae00a8c8151c6914b7b886a295844075c5039837824dd
sha256sums = 164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c
+ sha256sums = fe52b9b8331f6e5cc9fe95eb8de40bf40958fc38c26505fdd4d896b9055b1f25
pkgname = abricotine
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 1470b43213fe..9099332637af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,81 @@
-# Maintainer: Frank Seifferth <frankseifferth@posteo.net>
+# Maintainer:
+# Contributor: Frank Seifferth <frankseifferth@posteo.net>
# Contributor: Maxim Andersson <thesilentboatman@gmail.com>
+_ALL_OFF="$(tput sgr0)"
+_BOLD="${ALL_OFF}$(tput bold)"
+_BLACK="${BOLD}$(tput setaf 0)"
+_BLUE="${BOLD}$(tput setaf 4)"
+_CYAN="${BOLD}$(tput setaf 6)"
+_GREEN="${BOLD}$(tput setaf 2)"
+_MAGENTA="${BOLD}$(tput setaf 5)"
+_RED="${BOLD}$(tput setaf 1)"
+_WHITE="${BOLD}$(tput setaf 7)"
+_YELLOW="${BOLD}$(tput setaf 3)"
+
+notice() {
+ printf "${_WHITE} $1${_ALL_OFF}\n"
+}
+
+>&2 echo
+>&2 notice 'Abricotine development and support ceased in July 2023.'
+>&2 notice 'The developer recommends using a different editor because'
+>&2 notice 'Abricotine "hasn'\''t evolved in years and some dangerous'
+>&2 notice 'bugs have recently been reported"'
+>&2 notice
+>&2 notice 'https://github.com/brrd/abricotine/issues/347'
+
+for i in {1..5} ; do
+ >&2 sleep 1
+ >&2 echo -n '. '
+done
+>&2 echo
+
pkgname=abricotine
pkgver=1.1.4
-pkgrel=1
-pkgdesc="A markdown editor with inline preview"
+pkgrel=2
+pkgdesc="A markdown editor with inline preview (discontinued)"
+url="https://github.com/brrd/Abricotine/issues/347"
+license=('GPL-3.0-only')
arch=('x86_64')
-url="http://abricotine.brrd.fr"
-license=('GPL3')
-depends=('libxss')
-makedepends=('npm' 'nodejs')
-source=("abricotine-${pkgver}.tar.gz::https://github.com/brrd/abricotine/archive/${pkgver}.tar.gz"
- "abricotine.desktop")
-sha256sums=('1c1fd67770a75e3fc8cae00a8c8151c6914b7b886a295844075c5039837824dd'
- '164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c')
+
+depends=(
+ 'libnotify' # notify-send
+ 'libxss'
+)
+makedepends=(
+ 'npm'
+ 'nodejs'
+)
+
+_pkgsrc="abricotine-${pkgver}"
+source=(
+ "$_pkgsrc.tar.gz"::"https://github.com/brrd/abricotine/archive/${pkgver}.tar.gz"
+ "abricotine.desktop"
+ "abricotine.sh"
+)
+sha256sums=(
+ '1c1fd67770a75e3fc8cae00a8c8151c6914b7b886a295844075c5039837824dd'
+ '164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c'
+ 'fe52b9b8331f6e5cc9fe95eb8de40bf40958fc38c26505fdd4d896b9055b1f25'
+)
+
+install="abricotine.install"
build() {
- cd "${srcdir}/abricotine-${pkgver}"
+ cd "$_pkgsrc"
npm install --cache ../cache --devdir="${srcdir}/devdir"
npm run pack --cache ../cache --devdir="${srcdir}/devdir"
}
package() {
- cd "${srcdir}/abricotine-${pkgver}"
+ cd "$_pkgsrc"
install -d "${pkgdir}/opt/abricotine"
cp -r dist/linux-unpacked/* "${pkgdir}/opt/abricotine"
- install -d "${pkgdir}/usr/bin"
- ln -s "/opt/abricotine/abricotine" "${pkgdir}/usr/bin/abricotine"
+ install -Dm755 "../abricotine.sh" "${pkgdir}/usr/bin/abricotine"
install -Dm644 "../abricotine.desktop" -t "${pkgdir}/usr/share/applications/"
install -Dm644 "icons/abricotine@2x.png" "${pkgdir}/usr/share/pixmaps/abricotine.png"
diff --git a/abricotine.install b/abricotine.install
new file mode 100644
index 000000000000..038994675c6e
--- /dev/null
+++ b/abricotine.install
@@ -0,0 +1,36 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${BOLD} $1${ALL_OFF}\n"
+}
+
+note1() {
+ printf "${BLUE}==>${YELLOW} NOTE:${WHITE} $1${ALL_OFF}\n"
+}
+
+note2() {
+ printf "${BLUE}==> ${WHITE} $1${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="${ALL_OFF}$(tput bold)"
+BLACK="${BOLD}$(tput setaf 0)"
+RED="${BOLD}$(tput setaf 1)"
+GREEN="${BOLD}$(tput setaf 2)"
+YELLOW="${BOLD}$(tput setaf 3)"
+BLUE="${BOLD}$(tput setaf 4)"
+MAGENTA="${BOLD}$(tput setaf 5)"
+CYAN="${BOLD}$(tput setaf 6)"
+WHITE="${BOLD}$(tput setaf 7)"
+
+post_install() {
+ note1 'Abricotine development and support ceased in July 2023.'
+ note2 'The developer recommends using a different editor because'
+ note2 'Abricotine "hasn'\''t evolved in years and some dangerous'
+ note2 'bugs have recently been reported"'
+ note2
+ note2 'https://github.com/brrd/abricotine/issues/347'
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/abricotine.sh b/abricotine.sh
new file mode 100644
index 000000000000..65686601f375
--- /dev/null
+++ b/abricotine.sh
@@ -0,0 +1,36 @@
+#!/usr/bin/env bash
+
+notice() {
+ printf "${WHITE} $1${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="${ALL_OFF}$(tput bold)"
+BLACK="${BOLD}$(tput setaf 0)"
+RED="${BOLD}$(tput setaf 1)"
+GREEN="${BOLD}$(tput setaf 2)"
+YELLOW="${BOLD}$(tput setaf 3)"
+BLUE="${BOLD}$(tput setaf 4)"
+MAGENTA="${BOLD}$(tput setaf 5)"
+CYAN="${BOLD}$(tput setaf 6)"
+WHITE="${BOLD}$(tput setaf 7)"
+
+notice 'Abricotine development and support ceased in July 2023.'
+notice 'The developer recommends using a different editor because'
+notice 'Abricotine "hasn'\''t evolved in years and some dangerous'
+notice 'bugs have recently been reported"'
+notice
+notice 'https://github.com/brrd/abricotine/issues/347'
+echo
+
+if ! tty -s ; then
+ _message=''
+ _message+=' The developer recommends using a different editor because Abricotine'
+ _message+=' "hasn'\''t evolved in years and some dangerous bugs have recently'
+ _message+=' been reported".\n\n'
+
+ notify-send --urgency=critical -a "Abricotine" "Project discontinued" "$_message"
+fi
+
+sleep 2
+exec /opt/abricotine/abricotine "$@"