summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Seifferth2022-05-22 18:07:31 +0200
committerFrank Seifferth2022-05-22 18:07:31 +0200
commit94dcd43c7d8ec7fe300a56ef4337bffdabc63ad6 (patch)
treeb8a7d625469b04b17b591be6dda683c5fc3483c5
parentae03131120d4b7d5b1c9f9e3b7c133460c36e823 (diff)
downloadaur-94dcd43c7d8ec7fe300a56ef4337bffdabc63ad6.tar.gz
Update to v1.1.2
This includes changes to the source of the abricotine binary. Since no standalone binary is provided anymore, this *-bin package extracts the binary from the official abricotine debian package. Initial testing suggests that this binary also works well on arch.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 060dbbee0915..559b9e07400a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = abricotine-bin
pkgdesc = A markdown editor with inline preview
- pkgver = 1.0.0
+ pkgver = 1.1.2
pkgrel = 1
url = http://abricotine.brrd.fr
arch = x86_64
@@ -8,10 +8,9 @@ pkgbase = abricotine-bin
depends = libxss
provides = abricotine
conflicts = abricotine
- source = https://github.com/brrd/Abricotine/releases/download/1.0.0/abricotine-1.0.0-linux-x64.tar.gz
+ source = https://github.com/brrd/Abricotine/releases/download/v1.1.2/abricotine_1.1.2_amd64.deb
source = abricotine.desktop
- sha256sums = f3bbee75c7f5bc09e445546869582e1c7a09c0c269b22339f9cff79bd948c517
+ sha256sums = f75cca5504a74ff5d313ff6eb55ceed096a27c77c3d54eb4b1e4d6cb339ca96b
sha256sums = 164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c
pkgname = abricotine-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index 2cd8d4299ebc..4af6a7a96317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,34 @@ pkgname=abricotine-bin
_pkgname=abricotine
conflicts=("abricotine")
provides=("abricotine")
-pkgver=1.0.0
+pkgver=1.1.2
pkgrel=1
pkgdesc="A markdown editor with inline preview"
arch=('x86_64')
url="http://abricotine.brrd.fr"
license=('GPL3')
depends=('libxss')
-source=("https://github.com/brrd/Abricotine/releases/download/$pkgver/abricotine-$pkgver-linux-x64.tar.gz"
+source=("https://github.com/brrd/Abricotine/releases/download/v${pkgver}/abricotine_${pkgver}_amd64.deb"
"abricotine.desktop")
-sha256sums=('f3bbee75c7f5bc09e445546869582e1c7a09c0c269b22339f9cff79bd948c517'
+sha256sums=('f75cca5504a74ff5d313ff6eb55ceed096a27c77c3d54eb4b1e4d6cb339ca96b'
'164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c')
+prepare() {
+ cd "$srcdir"
+ tar xf data.tar.xz
+}
+
package() {
- cd "$srcdir/Abricotine-linux-x64"
+ cd "$srcdir"
install -d "$pkgdir/opt/abricotine"
- cp -r * "$pkgdir/opt/abricotine"
+ cp -r opt/Abricotine/* "$pkgdir/opt/abricotine"
install -d "$pkgdir/usr/bin"
ln -s "/opt/abricotine/abricotine" "$pkgdir/usr/bin/abricotine"
install -Dm644 "../abricotine.desktop" -t "$pkgdir/usr/share/applications/"
- install -Dm644 "icons/abricotine@2x.png" "$pkgdir/usr/share/pixmaps/abricotine.png"
+ install -Dm644 \
+ "usr/share/icons/hicolor/48x48/apps/abricotine.png" \
+ "$pkgdir/usr/share/pixmaps/abricotine.png"
}