summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFigue2015-06-09 01:26:17 +0200
committerFigue2015-06-09 01:26:17 +0200
commit90e3f5f86ef8dfb40b5ccbf49e3ba83703ba3538 (patch)
tree08352bc9c563f2bcae2e65a6a3fe6a18ec356ced
downloadaur-90e3f5f86ef8dfb40b5ccbf49e3ba83703ba3538.tar.gz
Initial import v37.0.2-1
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD37
-rw-r--r--abrowser.install11
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f51174842d1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by makepkg 4.2.1
+# Mon May 18 19:20:20 UTC 2015
+pkgbase = abrowser-bin
+ pkgdesc = Binary version of Abrowser, safe and easy web browser from Mozilla
+ pkgver = 37.0.2
+ pkgrel = 1
+ url = https://trisquel.info/en/wiki/abrowser-help
+ install = abrowser.install
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = gtk2
+ depends = gcc-libs
+ depends = libidl2
+ depends = mozilla-common
+ depends = nss>=3.12.10
+ depends = libxt
+ depends = libxrender
+ depends = hunspell
+ depends = startup-notification
+ depends = mime-types
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = libevent
+ depends = sqlite3>=3.7.4
+ depends = libnotify
+ depends = desktop-file-utils
+ depends = libvpx
+ depends = lcms
+ depends = nspr>=4.8.8
+ depends = libevent
+ depends = libpng
+ depends = cairo
+ depends = gnome-vfs
+ source = http://us.archive.trisquel.info/trisquel/pool/main/f/firefox/abrowser_37.0.2+build1-0ubuntu0.14.04.1+7.0trisquel37_amd64.deb
+ md5sums = bef142bd0343876c91c87ee67db9a239
+
+pkgname = abrowser-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e34e95493f6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Figue <ffigue at gmail dot com>
+
+pkgname=abrowser-bin
+pkgver=37.0.2
+pkgrel=1
+pkgdesc="Binary version of Abrowser, safe and easy web browser from Mozilla"
+arch=('i686' 'x86_64')
+license=('MPL' 'GPL' 'LGPL')
+url="https://trisquel.info/en/wiki/abrowser-help"
+depends=('gtk2' 'gcc-libs' 'libidl2' 'mozilla-common' 'nss>=3.12.10' 'libxt'
+ 'libxrender' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib'
+ 'alsa-lib' 'libevent' 'sqlite3>=3.7.4' 'libnotify' 'desktop-file-utils'
+ 'libvpx' 'lcms' 'nspr>=4.8.8' 'libevent' 'libpng' 'cairo' 'gnome-vfs')
+
+install=abrowser.install
+
+s_pkgname=abrowser
+build=build1
+ubuntu_ver=14.04.1
+trisquel_ver=7.0trisquel37
+
+if [ "${CARCH}" = 'x86_64' ]; then
+ ARCH='amd64'
+ md5sums=('bef142bd0343876c91c87ee67db9a239')
+elif [ "${CARCH}" = 'i686' ]; then
+ ARCH='i386'
+ md5sums=('0b4886dd77579af4205beca53ebb834a')
+fi
+
+source=("http://us.archive.trisquel.info/trisquel/pool/main/f/firefox/${s_pkgname}_${pkgver}+${build}-0ubuntu0.${ubuntu_ver}+${trisquel_ver}_${ARCH}.deb")
+
+package() {
+ tar xJvf ${srcdir}/data.tar.xz -C ${pkgdir}/
+ msg2 "Cleaning up unwanted files..."
+ rm -rv "${pkgdir}"/{etc/apport,etc/apparmor.d,usr/share/apport,usr/share/lintian}
+}
+
diff --git a/abrowser.install b/abrowser.install
new file mode 100644
index 000000000000..db2a6f475e53
--- /dev/null
+++ b/abrowser.install
@@ -0,0 +1,11 @@
+post_install () {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}