summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbepvte2019-01-18 09:44:51 -0500
committerbepvte2019-01-18 09:49:16 -0500
commite641f3427021cd6cec41115576ff8c0ffa6a0768 (patch)
tree23e88ff34f0f84a40594d50d43f454079395a5e7
downloadaur-abrus-gtk-theme-git.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--Install.patch19
-rw-r--r--PKGBUILD28
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2a4b58ffd37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = abrus-gtk-theme-git
+ pkgdesc = Abrus is a stylish Design theme for GTK 3, GTK 2 and Gnome-Shell
+ pkgver = 30.90db2d5
+ pkgrel = 1
+ url = https://vinceliuice.github.io/theme-abrus.html
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = patch
+ depends = gtk3
+ depends = gtk-engine-murrine
+ depends = gtk-engines
+ source = Install.patch
+ source = git+https://github.com/vinceliuice/Abrus-gtk-theme.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = abrus-gtk-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2cc9776470e7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+Abrus-gtk-theme/
+src/
+pkg/
+**/*.pkg.*
diff --git a/Install.patch b/Install.patch
new file mode 100644
index 000000000000..91560f93e6b1
--- /dev/null
+++ b/Install.patch
@@ -0,0 +1,19 @@
+diff --git a/Install b/Install
+index 14e6207..aae92b4 100755
+--- a/Install
++++ b/Install
+@@ -2,14 +2,6 @@
+ # Copying files
+
+ ROOT_UID=0
+-DEST_DIR=
+-
+-# Destination directory
+-if [ "$UID" -eq "$ROOT_UID" ]; then
+- DEST_DIR="/usr/share/themes"
+-else
+- DEST_DIR="$HOME/.themes"
+-fi
+
+ repodir=$(cd $(dirname $0) && pwd)
+ srcdir=${repodir}/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..541c43c24bf1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Paul Oppenheimer <bepvte@gmail.com>
+pkgname=abrus-gtk-theme-git
+_pkgname=Abrus-gtk-theme
+pkgdesc='Abrus is a stylish Design theme for GTK 3, GTK 2 and Gnome-Shell'
+pkgver=30.90db2d5
+pkgrel=1
+arch=('any')
+depends=('gtk3' 'gtk-engine-murrine' 'gtk-engines')
+license=('GPL3')
+source=('Install.patch'
+ 'git+https://github.com/vinceliuice/Abrus-gtk-theme.git')
+url='https://vinceliuice.github.io/theme-abrus.html'
+md5sums=('SKIP'
+ 'SKIP')
+makedepends=('git' 'patch')
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+build() {
+ cd "${srcdir}/${_pkgname}"
+ patch Install < "${srcdir}/Install.patch"
+}
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -m755 -d "${pkgdir}/usr/share/themes"
+ DEST_DIR="${pkgdir}/usr/share/themes" ./Install
+}