summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-11-03 15:29:36 +0100
committerAleksandar Trifunovic2018-11-03 15:29:36 +0100
commit7d47cfe599f385e40d05fc63c0e60c3fb3918e9e (patch)
tree8859e5c10f1f9dd3f18ec48596c98a56a88d765b
parentb98716962d6215f5d9fd8d1b80e77873f816ce6b (diff)
downloadaur-7d47cfe599f385e40d05fc63c0e60c3fb3918e9e.tar.gz
minor cleanup
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5733df533f02..9eadd6a975b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ makedepends=('cmake' 'git')
source=("$url/archive/$pkgver.tar.gz")
sha256sums=('794d483dd9a19c43dc1fbbe284ce8956eb7f2600ef350dac4c602f9b4eb26e90')
-build() {
+prepare() {
cd "$pkgname-$pkgver"
cmake -H. -Bbuild \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
@@ -21,8 +21,11 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DABSL_RUN_TESTS=ON \
- -DABSL_USE_GOOGLETEST_HEAD=ON \
+ -DABSL_USE_GOOGLETEST_HEAD=ON
+}
+build() {
+ cd "$pkgname-$pkgver"
cmake --build build
}
@@ -33,8 +36,7 @@ check() {
package() {
cd "$pkgname-$pkgver"
- # quick and dirty until official install comes (if not I should patch their
- # cmake files)
+
mkdir -p "$pkgdir/usr/include"
cp -a absl "$pkgdir/usr/include/absl"
mkdir "${pkgdir}/usr/lib/"