summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2018-07-04 14:43:23 +0200
committerMartin T. H. Sandsmark2018-07-04 14:43:39 +0200
commit1a9fe3950defb1da0b4e3606f8a8922ddb369061 (patch)
tree473eec452681f31d40972c3d0db4ca593c548fa2
downloadaur-1a9fe3950defb1da0b4e3606f8a8922ddb369061.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03c5b4fc7a3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = abseil-cpp-git
+ pkgdesc = An open-source collection of C++ code to augment the C++ standard library
+ pkgver = r180.8f612eb
+ pkgrel = 1
+ url = https://github.com/sandsmark/abseil-cpp
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = doxygen
+ provides = abseil-cpp
+ conflicts = abseil-cpp
+ source = git+https://github.com/abseil/abseil-cpp.git
+ md5sums = SKIP
+
+pkgname = abseil-cpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc987d78454e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+
+pkgname=abseil-cpp-git
+pkgver=r180.8f612eb
+pkgrel=1
+pkgdesc='An open-source collection of C++ code to augment the C++ standard library'
+arch=('i686' 'x86_64')
+url='https://github.com/abseil/abseil-cpp'
+license=('LGPL')
+depends=()
+makedepends=('cmake' 'git')
+conflicts=(abseil-cpp)
+provides=(abseil-cpp)
+source=('git+https://github.com/abseil/abseil-cpp.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd abseil-cpp
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../abseil-cpp
+ make
+}
+
+package() {
+ LIBS=('algorithm' 'base' 'container' 'debugging' 'memory' 'meta' 'numeric' 'strings' 'synchronization' 'time' 'types' 'utility')
+ mkdir -p "${pkgdir}/usr/lib/"
+ for LIB in "${LIBS[@]}"; do
+ mkdir -p "${pkgdir}/usr/include/absl/${LIB}"
+ install -m644 build/absl/${LIB}/*.a "${pkgdir}/usr/lib/"
+ install -m644 abseil-cpp/absl/${LIB}/*.h "${pkgdir}/usr/include/absl/${LIB}"
+ done
+}