summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2024-01-21 15:43:04 +0000
committerccorn2024-01-21 15:43:04 +0000
commit5e2e6340337165f101972daa86255493aaacf527 (patch)
tree588653ca0bbf06ed41f07bb8299ee014857a5ea8
parent6e84f00364a1cd4f8257a30c6bd95bf1de601f03 (diff)
downloadaur-5e2e6340337165f101972daa86255493aaacf527.tar.gz
abseil-cpp11: Add runtime path setting for easier usage (#354)
* Add runtime path setting for easier usage. Installation into a non-standard libdir needs a runtime path setting to be usable without LD_LIBRARY_PATH hacks. With this change, users of this version only need to add -Dabsl_DIR=/usr/lib/abseil-cpp11/cmake/absl \ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=ON to their cmake command line. See also: <https://aur.archlinux.org/packages/abseil-cpp11#comment-952772> * Increment pkgrel
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a30e2ceb30c0..b75d833b3346 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = abseil-cpp11
pkgdesc = Common C++ libraries (legacy for C++11)
pkgver = 20220623.1
- pkgrel = 1
+ pkgrel = 2
url = https://abseil.io
arch = aarch64
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c73b2231782b..76c9524437db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_name=abseil-cpp
pkgname=abseil-cpp11
pkgver=20220623.1
-pkgrel=1
+pkgrel=2
pkgdesc='Common C++ libraries (legacy for C++11)'
arch=(aarch64 x86_64)
url='https://abseil.io'
@@ -23,6 +23,8 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_INCLUDEDIR=/usr/include/$pkgname \
-DCMAKE_INSTALL_LIBDIR=lib/$pkgname \
+ -DCMAKE_SKIP_INSTALL_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH=/usr/lib/$pkgname \
-DCMAKE_CXX_STANDARD=11 \
-DBUILD_SHARED_LIBS=ON \
-DABSL_USE_EXTERNAL_GOOGLETEST=ON \