summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClar Fon2019-10-10 19:35:19 -0400
committerClar Fon2019-10-10 19:41:22 -0400
commit30894fc897cfc422a389ec50a18060d8c6bd6068 (patch)
treece5778dc8a023525affd238125cbffd8aee0925c
parenta3dc59267c80daf208920ec84066208fe17a1faf (diff)
downloadaur-30894fc897cfc422a389ec50a18060d8c6bd6068.tar.gz
Use /bin/dash instead of /bin/ash
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baec31033d65..9521dd14bae1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = abuild
pkgdesc = Script to build Alpine Packages
pkgver = 3.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://git.alpinelinux.org/cgit/abuild/
arch = i686
arch = x86_64
license = GPL2
makedepends = zlib
makedepends = pkgconfig
+ depends = dash
depends = glibc
depends = pax-utils
depends = openssl
diff --git a/PKGBUILD b/PKGBUILD
index 92cf2e39fbb0..3d20fb9db892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname="abuild"
pkgver=3.4.0
_ver=${pkgver%_git*}
-pkgrel=1
+pkgrel=2
pkgdesc="Script to build Alpine Packages"
url="https://git.alpinelinux.org/cgit/abuild/"
arch=("i686" "x86_64")
license=("GPL2")
makedepends=("zlib" "pkgconfig")
-depends=("glibc" "pax-utils" "openssl" "apk-tools" "attr" "tar" "pkgconf" "lzip" "curl"
+depends=("dash" "glibc" "pax-utils" "openssl" "apk-tools" "attr" "tar" "pkgconf" "lzip" "curl"
"bubblewrap" "gettext" "git")
opt_depends=("perl: for cpan resolver"
"perl-libwww: for cpan resolver"
@@ -36,6 +36,9 @@ build() {
package() {
cd "$srcdir/$pkgname-$_ver"
make install VERSION="$pkgver-r$pkgrel" DESTDIR="$pkgdir"
+ for bin in "$pkgdir"/usr/bin/*; do
+ sed -e "1s|#!/bin/ash|#!/bin/dash|" -i "$bin"
+ done
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
install -d -m 775 -o nobody -g nobody "$pkgdir"/var/cache/distfiles
}