summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Mielniczuk2018-05-18 09:51:28 +0200
committerMarcin Mielniczuk2018-05-18 09:51:28 +0200
commit42e6f5e8e286062603cf74fca8c78c82f75b5f9b (patch)
treeeccbfa85d87d6157ea091558dee7eb9af3c0f69e
parent7c88164ed3b6ea5ea522875f8356a9f956f99d00 (diff)
downloadaur-42e6f5e8e286062603cf74fca8c78c82f75b5f9b.tar.gz
Initial upload
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05f2e19ab88b..acce6a1de30b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = abuild
- pkgdesc = Script to build Alpine packages
- pkgver = 2.29.0
+ pkgdesc = Build script to build Alpine packages
+ pkgver = 3.2.0_rc1
pkgrel = 1
- url = http://git.alpinelinux.org/cgit/abuild/
+ url = https://alpinelinux.org
arch = i686
arch = x86_64
license = GPL2
- depends = curl
- depends = openssl
- source = http://dev.alpinelinux.org/archive/abuild/abuild-2.29.0.tar.xz
- md5sums = 1a51f8786331ddf79bf46357fe938f6a
+ makedepends = git
+ source = git+https://git.alpinelinux.org/cgit/abuild#tag=v3.2.0_rc1
+ sha1sums = SKIP
pkgname = abuild
diff --git a/PKGBUILD b/PKGBUILD
index 956680ea52ca..4c98f26acf7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,23 @@
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
-# Maintainer: Łukasz Jendrysik <scadu@yandex.com>
+# Maintainer: Marcin Mielniczuk <marmistrz@inboxalias.com>
pkgname=abuild
-pkgver=2.29.0
+pkgver=3.2.0_rc1
pkgrel=1
-pkgdesc='Script to build Alpine packages'
+pkgdesc="Build script to build Alpine packages"
arch=('i686' 'x86_64')
-url='http://git.alpinelinux.org/cgit/abuild/'
+url="https://alpinelinux.org"
license=('GPL2')
-depends=('curl' 'openssl')
-source=(http://dev.alpinelinux.org/archive/abuild/abuild-$pkgver.tar.xz)
-md5sums=('1a51f8786331ddf79bf46357fe938f6a')
-
-prepare() {
- cd $pkgname-$pkgver
- sed -i -e "/^CHOST=/s/=.*/=$CHOST/" abuild.conf
-}
-
+makedepends=('git')
+source=("git+https://git.alpinelinux.org/cgit/abuild#tag=v${pkgver}")
+sha1sums=("SKIP")
build() {
- cd $pkgname-$pkgver
- make
+ cd "${srcdir}/${pkgname}"
+ sed -i "s_/bin/ash_/bin/bash_g" abuild.in
+ make
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- install -Dm644 abuild.conf "$pkgdir"/etc/abuild.conf
+ cd "${srcdir}/${pkgname}"
+ make install DESTDIR="$pkgdir"
}
+