summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic2023-08-26 20:49:43 +0200
committerDominic2023-08-26 20:49:43 +0200
commit458780425f6a7a16e7680ef0bf35cd66ec155dd5 (patch)
treee4a44cb37e7b55cd2107ce24c5091bc45f0172d0
parente316dd776ad37e8345d42a479949f6833eb0c4e5 (diff)
downloadaur-458780425f6a7a16e7680ef0bf35cd66ec155dd5.tar.gz
abuild 3.11.21-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3104ba0ad07..ff7816f3c15a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = abuild
pkgdesc = Script to build Alpine Packages
- pkgver = 3.10.0
- pkgrel = 2
+ pkgver = 3.11.21
+ pkgrel = 1
url = https://git.alpinelinux.org/cgit/abuild/
arch = i686
arch = x86_64
@@ -29,7 +29,7 @@ pkgbase = abuild
optdepends = perl-lwp-protocol-https: for cpan resolver
optdepends = ruby: for gem resolver
optdepends = ruby-augeas: for gem resolver
- source = https://git.alpinelinux.org/abuild/snapshot/abuild-3.10.0.tar.gz
- sha512sums = 5acf9f2b0681ae1bc83505699769d3042b9380008f8fe064bc87fc6280bbe25ec76ea6f5c356c3bb0fa123b575f89e98319b3bca21d642cce3f0bcba1a39c2fc
+ source = https://gitlab.alpinelinux.org/alpine/abuild/-/archive/3.11.21/abuild-3.11.21.tar.gz
+ sha512sums = 798cfed101c8660feb872375353a99065642220d5b6e88779b87716f5b50a456f456d24b9c9def8ebe4e01a3e67a080c2686cf6f54a4410b364ed98f4fcbbec8
pkgname = abuild
diff --git a/PKGBUILD b/PKGBUILD
index ad6141f90ab0..7f6a006aa342 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Clar Fon <them@lightdark.xyz>
pkgname="abuild"
-pkgver=3.10.0
+pkgver=3.11.21
_ver=${pkgver%_git*}
-pkgrel=2
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="https://git.alpinelinux.org/cgit/abuild/"
arch=("i686" "x86_64")
@@ -18,12 +18,12 @@ optdepends=("perl: for cpan resolver"
"perl-lwp-protocol-https: for cpan resolver"
"ruby: for gem resolver"
"ruby-augeas: for gem resolver")
-source=("https://git.alpinelinux.org/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('5acf9f2b0681ae1bc83505699769d3042b9380008f8fe064bc87fc6280bbe25ec76ea6f5c356c3bb0fa123b575f89e98319b3bca21d642cce3f0bcba1a39c2fc')
+source=("https://gitlab.alpinelinux.org/alpine/abuild/-/archive/$pkgver/abuild-$pkgver.tar.gz")
+sha512sums=('798cfed101c8660feb872375353a99065642220d5b6e88779b87716f5b50a456f456d24b9c9def8ebe4e01a3e67a080c2686cf6f54a4410b364ed98f4fcbbec8')
prepare() {
cd "$srcdir/$pkgname-$_ver"
- sed -i -e "/^CHOST=/s/=.*/=$CARCH/" abuild.conf
+ #sed -i -e "/^CHOST=/s/=.*/=$CARCH/" abuild.conf
}
build() {