summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvenom2021-01-17 16:36:06 -0800
committervenom2021-01-17 16:36:06 -0800
commitbe9d263066674e64d97d21af7455e0a8ccc1c58b (patch)
treedbe27951e23dcb9911398607b463200393cb170d
parent30894fc897cfc422a389ec50a18060d8c6bd6068 (diff)
downloadaur-be9d263066674e64d97d21af7455e0a8ccc1c58b.tar.gz
update package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9521dd14bae1..6086d4c3366d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = abuild
pkgdesc = Script to build Alpine Packages
- pkgver = 3.4.0
- pkgrel = 2
+ pkgver = 3.7.0
+ pkgrel = 1
url = https://git.alpinelinux.org/cgit/abuild/
arch = i686
arch = x86_64
license = GPL2
makedepends = zlib
makedepends = pkgconfig
- depends = dash
+ depends = busybox
depends = glibc
depends = pax-utils
depends = openssl
@@ -21,8 +21,7 @@ pkgbase = abuild
depends = bubblewrap
depends = gettext
depends = git
- source = https://dev.alpinelinux.org/archive/abuild/abuild-3.4.0.tar.xz
- sha512sums = 0ddf1cef2e79628a4de06015ba217432711ee76751ccc487fd3b1af9cae37ed1b8c5afdc0b916322472314ccee8a6d1c17ccb5b55f6eebfb54444199d2281d3e
+ source = https://git.alpinelinux.org/abuild/snapshot/abuild-3.7.0.tar.gz
+ sha512sums = d807cf37a355e1a43e9cb34108a301e6823b4502e7d932097027c62434bde94cc2a439d4c95c882a1cea41ad8b32424e323be20b163c59e8b1747e670a9f3909
pkgname = abuild
-
diff --git a/PKGBUILD b/PKGBUILD
index 3d20fb9db892..785fe80d6a89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Maintainer: Clar Fon <them@lightdark.xyz>
pkgname="abuild"
-pkgver=3.4.0
+pkgver=3.7.0
_ver=${pkgver%_git*}
-pkgrel=2
+pkgrel=1
pkgdesc="Script to build Alpine Packages"
url="https://git.alpinelinux.org/cgit/abuild/"
arch=("i686" "x86_64")
license=("GPL2")
makedepends=("zlib" "pkgconfig")
-depends=("dash" "glibc" "pax-utils" "openssl" "apk-tools" "attr" "tar" "pkgconf" "lzip" "curl"
+depends=("busybox" "glibc" "pax-utils" "openssl" "apk-tools" "attr" "tar" "pkgconf" "lzip" "curl"
"bubblewrap" "gettext" "git")
opt_depends=("perl: for cpan resolver"
"perl-libwww: for cpan resolver"
@@ -20,8 +20,8 @@ opt_depends=("perl: for cpan resolver"
"ruby: for gem resolver"
"ruby-augeas: for gem resolver")
pkggroups="abuild"
-source=("https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_ver.tar.xz")
-sha512sums=("0ddf1cef2e79628a4de06015ba217432711ee76751ccc487fd3b1af9cae37ed1b8c5afdc0b916322472314ccee8a6d1c17ccb5b55f6eebfb54444199d2281d3e")
+source=("https://git.alpinelinux.org/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('d807cf37a355e1a43e9cb34108a301e6823b4502e7d932097027c62434bde94cc2a439d4c95c882a1cea41ad8b32424e323be20b163c59e8b1747e670a9f3909')
prepare() {
cd "$srcdir/$pkgname-$_ver"
@@ -37,7 +37,7 @@ package() {
cd "$srcdir/$pkgname-$_ver"
make install VERSION="$pkgver-r$pkgrel" DESTDIR="$pkgdir"
for bin in "$pkgdir"/usr/bin/*; do
- sed -e "1s|#!/bin/ash|#!/bin/dash|" -i "$bin"
+ sed -e "1s|#!/bin/ash|#!/bin/busybox ash|" -i "$bin"
done
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
install -d -m 775 -o nobody -g nobody "$pkgdir"/var/cache/distfiles