summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaute Hope2016-03-10 12:37:56 +0100
committerGaute Hope2016-03-10 12:37:56 +0100
commita6ff47d902dca7da9428c105b5f466eec196aa0b (patch)
tree63e5bbaec8b694658d589417367fedbed536b10b
downloadaur-a6ff47d902dca7da9428c105b5f466eec196aa0b.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD48
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8afd229754d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Mar 10 11:37:43 UTC 2016
+pkgbase = abunchoftags
+ pkgdesc = a keyword <-> tag sync utility for notmuch and offlineimap/GMail
+ pkgver = 0651600
+ pkgrel = 1
+ url = https://github.com/gauteh/abunchoftags
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = scons
+ makedepends = git
+ makedepends = pkg-config
+ depends = notmuch
+ depends = boost
+ depends = boost-libs
+ depends = gmime
+ source = abunchoftags::git+https://github.com/gauteh/abunchoftags.git
+ md5sums = SKIP
+
+pkgname = abunchoftags
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31a07b9b6559
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+abunchoftags*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82884dfaa27f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Gaute Hope <eg@gaute.vetsj.com>
+pkgname=abunchoftags
+pkgver=0651600
+pkgrel=1
+epoch=
+pkgdesc="a keyword <-> tag sync utility for notmuch and offlineimap/GMail"
+arch=('x86_64' 'i686')
+url="https://github.com/gauteh/abunchoftags"
+license=('GPL')
+groups=()
+depends=('notmuch' 'boost' 'boost-libs' 'gmime')
+makedepends=('scons' 'git' 'pkg-config')
+checkdepends=('')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(abunchoftags::git+https://github.com/gauteh/abunchoftags.git)
+noextract=()
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ scons
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/abunchoftags/"
+
+ cp keywsync "${pkgdir}/usr/bin/"
+ cp examples/fetch_and_sync.sh "${pkgdir}/usr/share/abunchoftags/"
+
+ if [ -e notmuch_get_revision ]; then
+ cp notmuch_get_revision "${pkgdir}/usr/bin/"
+ fi
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+