summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuoi2023-05-14 22:30:08 +0800
committerKuoi2023-05-14 22:30:08 +0800
commitdb27f03337ca367fdab7d8bbff9c1c9519b46da7 (patch)
treefcba6d6e2561784fc427a5955f8f2e6183296c48
parentfb534ed6b784d1e16cf89b497d9611775f974621 (diff)
downloadaur-db27f03337ca367fdab7d8bbff9c1c9519b46da7.tar.gz
2.3.6: fix and format
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9afbb841c179..7d3c74f88833 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,12 +8,12 @@ pkgbase = abyss
license = GPL3
makedepends = boost
makedepends = sparsehash
- depends = make
+ makedepends = make
+ makedepends = btllib
depends = openmpi
- depends = sqlite
+ depends = make
optdepends = pigz: for parallel gzip
- optdepends = samtools: to read BAM files
- optdepends = zsh: to report time and memory usage
+ optdepends = samtools: for reading SAM files
source = abyss-2.3.6.tar.gz::https://github.com/bcgsc/abyss/archive/2.3.6.tar.gz
sha512sums = bc535f2676f6ed9929219680fb301787bffa527892c46f96c10d4e998cd7a7cf88df689f04e3bb4333d4a8ec7f098f6bd45b1a0e20877674d003c7f57eca5268
diff --git a/PKGBUILD b/PKGBUILD
index b476a8b4558e..5367a7016b84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: PolpOnline <aur at t0mmy dot anonaddy dot com>
+# Maintainer: Guoyi ZHang <myname at malacology dot net>
+# Contributor: PolpOnline <aur at t0mmy dot anonaddy dot com>
# Contributor: Eric Biggers <ebiggers3 at gmail dot com>
pkgname=abyss
@@ -8,29 +9,20 @@ pkgdesc="Assembly By Short Sequences - a de novo, parallel, paired-end sequence
arch=("i686" "x86_64")
url="https://github.com/bcgsc/abyss"
license=("GPL3")
-depends=("make" "openmpi" "sqlite")
-makedepends=("boost" "sparsehash")
+depends=("openmpi" "make")
+makedepends=("boost" "sparsehash" "make" "btllib")
optdepends=(
'pigz: for parallel gzip'
- 'samtools: to read BAM files'
- 'zsh: to report time and memory usage'
+ 'samtools: for reading SAM files'
)
source=("$pkgname-$pkgver.tar.gz::https://github.com/bcgsc/abyss/archive/$pkgver.tar.gz")
sha512sums=('bc535f2676f6ed9929219680fb301787bffa527892c46f96c10d4e998cd7a7cf88df689f04e3bb4333d4a8ec7f098f6bd45b1a0e20877674d003c7f57eca5268')
build() {
cd "${pkgname}-${pkgver}"
-
./autogen.sh
- LDFLAGS="${LDFLAGS:-} -L/usr/lib/openmpi" \
- ./configure --prefix=/usr --disable-werror
- make
-}
-
-check() {
- cd "${pkgname}-${pkgver}"
-
- make check
+ ./configure --prefix=/usr --with-boost=/usr/lib --with-mpi=/usr/lib/openmpi --with-sparsehash=/usr/lib --with-btllib=/usr/lib --without-sqlite --disable-werror
+ make
}
package() {