summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-06 21:40:15 +0800
committerzxp198210052024-04-06 21:40:15 +0800
commit49b3f3a3c00abc282fa2977e38b589e9d9744123 (patch)
treea9a5ad62eed2d0e859edde9b14f8b305798d20f6
downloadaur-49b3f3a3c00abc282fa2977e38b589e9d9744123.tar.gz
update to 0.3.9
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..963ec5066d37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = acast-bin
+ pkgdesc = A free and open source solution for recording terminal sessions and sharing them on the web.一个免费开源的终端会话录制和分享工具
+ pkgver = 0.3.9
+ pkgrel = 1
+ url = https://asciinema.org/
+ arch = aarch64
+ arch = x86_64
+ license = MIT
+ provides = asciinema
+ conflicts = acast
+ conflicts = asciinema
+ source = LICENSE-0.3.9::https://raw.githubusercontent.com/gvcgo/asciinema/main/LICENSE
+ sha256sums = 7c7fdee1ffc06fe95ad9f1179188bab5c7a37f360b5876c8f13670d1ba3af22c
+ source_aarch64 = acast-0.3.9-aarch64.zip::https://github.com/gvcgo/asciinema/releases/download/v0.3.9/acast_linux-arm64.zip
+ sha256sums_aarch64 = 7f0ff216b737901f28d0f909c7f8e0d9576d633a66bfbe97ae37e57551979dde
+ source_x86_64 = acast-0.3.9-x86_64.zip::https://github.com/gvcgo/asciinema/releases/download/v0.3.9/acast_linux-amd64.zip
+ sha256sums_x86_64 = 70136c9e10b7dcf53ef9dcbb28dc4dc22f494f175f06b988c367849ad892dfcb
+
+pkgname = acast-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..844742a8c26d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=acast-bin
+_pkgname=asciinema
+pkgver=0.3.9
+pkgrel=1
+pkgdesc="A free and open source solution for recording terminal sessions and sharing them on the web.一个免费开源的终端会话录制和分享工具"
+arch=(
+ "aarch64"
+ "x86_64"
+)
+url="https://asciinema.org/"
+_ghurl="https://github.com/gvcgo/asciinema"
+license=('MIT')
+provides=("${_pkgname}")
+conflicts=(
+ "${pkgname%-bin}"
+ "${_pkgname}"
+)
+depends=()
+source=(
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/gvcgo/asciinema/main/LICENSE"
+)
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_linux-arm64.zip")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_linux-amd64.zip")
+sha256sums=('7c7fdee1ffc06fe95ad9f1179188bab5c7a37f360b5876c8f13670d1ba3af22c')
+sha256sums_aarch64=('7f0ff216b737901f28d0f909c7f8e0d9576d633a66bfbe97ae37e57551979dde')
+sha256sums_x86_64=('70136c9e10b7dcf53ef9dcbb28dc4dc22f494f175f06b988c367849ad892dfcb')
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+} \ No newline at end of file