summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0xMRTT2022-10-01 20:57:03 +0200
committer0xMRTT2022-10-01 20:57:03 +0200
commite212ae55d847b2b14e2e59f731b0bf3326b8d689 (patch)
tree231943264d3305035b369569590c43a6a2e2617b
downloadaur-e212ae55d847b2b14e2e59f731b0bf3326b8d689.tar.gz
feat: first version
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f175b539953c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = accumulate-git
+ pkgdesc = Accumulate anonymous GNOME data
+ pkgver = r4.9632f61
+ pkgrel = 1
+ url = https://github.com/Atrophaneura/Accumulate
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ makedepends = blueprint-compiler
+ makedepends = gobject-introspection
+ depends = libadwaita
+ depends = python-gobject
+ provides = accumulate
+ conflicts = accumulate
+ conflicts = accumulate-git
+ source = git+https://github.com/Atrophaneura/Accumulate.git
+ b2sums = SKIP
+
+pkgname = accumulate-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..410e9a9e64e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: 0xMRTT < 0xMRTT at proton dot me >
+
+pkgname=accumulate-git
+_pkgname=Accumulate
+pkgver=r4.9632f61
+pkgrel=1
+pkgdesc="Accumulate anonymous GNOME data"
+arch=('x86_64')
+url="https://github.com/Atrophaneura/Accumulate"
+license=('GPL3')
+depends=('libadwaita' 'python-gobject')
+makedepends=('git' 'meson' 'blueprint-compiler' 'gobject-introspection')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" accumulate-git)
+source=(git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ arch-meson "${_pkgname%-git}" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}