summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShapeShifter4992015-07-23 00:14:09 -0700
committerShapeShifter4992015-07-23 00:14:09 -0700
commit47f7cd7c7b869695f3610c7a8fdfec19e2924dd9 (patch)
treeff60c847b01b66b3bf49178ba5e0be75d172af57
downloadaur-47f7cd7c7b869695f3610c7a8fdfec19e2924dd9.tar.gz
Inital Upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e82595a9a7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = acd_cli-git
+ pkgdesc = acd_cli provides a command line interface to Amazon Cloud Drive and allows mounting your cloud drive using FUSE for read access. It is currently in beta stage.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/yadayada/acd_cli
+ arch = any
+ license = GPL
+ makedepends = python
+ depends = python-appdirs
+ depends = python-requests>=2.1.0
+ depends = python-sqlalchemy
+ depends = python-dateutils
+ depends = python-requests-toolbelt
+ provides = acd_cli
+ source = git+https://github.com/yadayada/acd_cli.git
+ md5sums = SKIP
+
+pkgname = acd_cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70f49689b62e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Your Name <youremail@domain.com>
+_pkgname=acd_cli
+pkgname=$_pkgname-git
+pkgver=1
+pkgrel=1
+pkgdesc="acd_cli provides a command line interface to
+Amazon Cloud Drive and allows mounting your cloud drive
+using FUSE for read access. It is currently in beta
+stage."
+arch=('any')
+url="https://github.com/yadayada/acd_cli"
+license=('GPL')
+depends=('python-appdirs' 'python-requests>=2.1.0'
+'python-sqlalchemy' 'python-dateutils'
+'python-requests-toolbelt')
+makedepends=('python')
+provides=('acd_cli')
+conficts=('acd_cli')
+source=(git+https://github.com/yadayada/acd_cli.git)
+md5sums=('SKIP')
+
+package() {
+ cd $_pkgname
+ python setup.py install
+}