summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShapeShifter4992015-07-23 02:43:21 -0700
committerShapeShifter4992015-07-23 02:43:21 -0700
commitf1eb79c6fbd2b28280e91b4d45c0fa5e6511a63c (patch)
tree3b6dc6f13b158a0f989df30525cdb3735f52ac01
parent120d0d0078e395e0bb3ae40da5dfb3cb9214e799 (diff)
downloadaur-f1eb79c6fbd2b28280e91b4d45c0fa5e6511a63c.tar.gz
Making sure the package notes who is developer and package maintainer v3
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41b0cfb20d21..e8daa6ef0839 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,6 +21,12 @@ conficts=('acd_cli')
source=(git+https://github.com/yadayada/acd_cli.git)
md5sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
package() {
cd $_pkgname
python setup.py install --root="$pkgdir/" --optimize=1