summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-07-31 15:28:29 +0900
committerBenjamin Chrétien2015-07-31 15:28:29 +0900
commitb55eb338af9dccc9785cbd983be90323f2c7a28b (patch)
tree3a45ac076737bb64028dabe7e6243771f45b4d5b
downloadaur-b55eb338af9dccc9785cbd983be90323f2c7a28b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--license.txt83
3 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86ee58baad39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ace
+ pkgdesc = Framework that provides many components and patterns for developing high-performance, distributed real-time and embedded systems.
+ pkgver = 6.3.1
+ pkgrel = 1
+ url = http://www.cs.wustl.edu/~schmidt/ACE.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ conflicts = libace
+ options = !libtool
+ source = http://download.dre.vanderbilt.edu/previous_versions/ACE-6.3.1.tar.gz
+ source = license.txt
+ sha1sums = 6b1256b259b699f9e6747bc3b53b48885e18a4af
+ sha1sums = b21054d0aa546fabe4bb0c2769401314d4a5bfe3
+
+pkgname = ace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..539f905348fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: DaNiMoTh <jjdanimoth@gmail.com>
+# Contributor: Andrea Scarpino <bash.lnx@gmail.com>
+# Contributor: Gereon Schomber <Gereon_Schomber@fastmail.fm>
+# Contributor: Alex Belanger <i.caught.air@gmail.com>
+
+pkgname=ace
+pkgver=6.3.1
+pkgrel=1
+pkgdesc="Framework that provides many components and patterns for developing high-performance, distributed real-time and embedded systems."
+url="http://www.cs.wustl.edu/~schmidt/ACE.html"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=()
+options=(!libtool)
+conflicts=('libace')
+source=(http://download.dre.vanderbilt.edu/previous_versions/ACE-${pkgver}.tar.gz
+ license.txt)
+
+build() {
+ export ACE_ROOT=$srcdir/ACE_wrappers
+ cd $ACE_ROOT
+ echo '#include "ace/config-linux.h"' > ace/config.h
+ echo 'INSTALL_PREFIX = /usr
+ include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU' > include/makeinclude/platform_macros.GNU
+ cd ace
+ make
+}
+package() {
+ cd $srcdir/ACE_wrappers/ace
+ make DESTDIR="$pkgdir/" install
+}
+sha1sums=('6b1256b259b699f9e6747bc3b53b48885e18a4af'
+ 'b21054d0aa546fabe4bb0c2769401314d4a5bfe3')
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..f4d029f1ef6d
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,83 @@
+Copyright and Licensing Information for ACE(TM), TAO(TM), CIAO(TM), and
+CoSMIC(TM)
+ACE(TM), TAO(TM), CIAO(TM), and CoSMIC(TM) (henceforth referred to as
+"DOC software") are copyrighted by Douglas C. Schmidt and his research
+group at Washington University, University of California, Irvine, and
+Vanderbilt University, Copyright (c) 1993-2006, all rights reserved.
+Since DOC software is open-source, freely available software, you are
+free to use, modify, copy, and distribute--perpetually and
+irrevocably--the DOC software source code and object code produced from
+the source, as well as copy and distribute modified versions of this
+software. You must, however, include this copyright statement along with
+any code built using DOC software that you release. No copyright
+statement needs to be provided if you just ship binary executables of
+your software products.
+
+You can use DOC software in commercial and/or binary software releases
+and are under no obligation to redistribute any of your source code that
+is built using DOC software. Note, however, that you may not do anything
+to the DOC software code, such as copyrighting it yourself or claiming
+authorship of the DOC software code, that will prevent DOC software from
+being distributed freely using an open-source development model. You
+needn't inform anyone that you're using DOC software in your software,
+though we encourage you to let us know so we can promote your project in
+the DOC software success stories.
+
+The ACE, TAO, CIAO, and CoSMIC web sites are maintained by the DOC Group
+at the Institute for Software Integrated Systems (ISIS) and the Center
+for Distributed Object Computing of Washington University, St. Louis for
+the development of open-source software as part of the open-source
+software community. By submitting comments, suggestions, code, code
+snippets, techniques (including that of usage) and algorithms
+(collectively ``Submissions''), submitters acknowledge that they have
+the right to do so, that any such Submissions are given freely and
+unreservedly, and that they waive any claims to copyright or ownership.
+In addition, submitters acknowledge that any such Submission might
+become part of the copyright maintained on the overall body of code that
+comprises the DOC software. By making a Submission, submitter agree to
+these terms. Moreover, submitters acknowledge that the incorporation or
+modification of such Submissions is entirely at the discretion of the
+moderators of the open-source DOC software projects or their designees.
+
+Submissions are provided by the submitter ``as is'' with no warranties
+whatsoever, including any warranty of merchantability, noninfringement
+of third party intellectual property, or fitness for any particular
+purpose. In no event shall the submitter be liable for any direct,
+indirect, special, exemplary, punitive, or consequential damages,
+including without limitation, lost profits, even if advised of the
+possibility of such damages. Likewise, DOC software is provided as is
+with no warranties of any kind, including the warranties of design,
+merchantability, and fitness for a particular purpose, noninfringement,
+or arising from a course of dealing, usage or trade practice. Washington
+University, UC Irvine, Vanderbilt University, their employees, and
+students shall have no liability with respect to the infringement of
+copyrights, trade secrets or any patents by DOC software or any part
+thereof. Moreover, in no event will Washington University, UC Irvine, or
+Vanderbilt University, their employees, or students be liable for any
+lost revenue or profits or other special, indirect and consequential
+damages.
+
+DOC software is provided with no support and without any obligation on
+the part of Washington University, UC Irvine, Vanderbilt University,
+their employees, or students to assist in its use, correction,
+modification, or enhancement. A number of companies around the world
+provide commercial support for DOC software, however.
+
+DOC software is Y2K-compliant, as long as the underlying OS platform is
+Y2K-compliant. Likewise, DOC software is compliant with the new US
+daylight savings rule passed by Congress as "The Energy Policy Act of
+2005," which established new daylight savings times (DST) rules for the
+United States that expand DST as of March 2007. Since DOC software
+obtains time/date and calendaring information from operating systems
+users will not be affected by the new DST rules as long as they upgrade
+their operating systems accordingly.
+
+The names ACE(TM), TAO(TM), CIAO(TM), CoSMIC(TM), Washington University,
+UC Irvine, and Vanderbilt University, may not be used to endorse or
+promote products or services derived from this source without express
+written permission from Washington University, UC Irvine, or Vanderbilt
+University. Further, products or services derived from this source may
+not be called ACE(TM), TAO(TM), CIAO(TM), or CoSMIC(TM) nor may the name
+Washington University, UC Irvine, or Vanderbilt University appear in
+their names, without express written permission from Washington
+University, UC Irvine, and Vanderbilt University.