summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-11-22 18:45:41 +0100
committerkleintux2022-11-22 18:45:41 +0100
commit2de8781cbfeb612ae2e8e7e3d4cfe3b35f7c14e3 (patch)
tree27aba2f6d488090487a09ec8ccf72d2e650fadfb
parent1c2d55d3b80246d67e7522be034596654064ba5b (diff)
downloadaur-ace-of-penguins.tar.gz
added patch from bown
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--badmatch.patch11
3 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53fbe21e5ef6..8fd1715aed7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ace-of-penguins
pkgdesc = A set of Unix/X solitaire games.
pkgver = 1.4
- pkgrel = 5
+ pkgrel = 6
url = https://www.delorie.com/store/ace/
arch = i686
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = ace-of-penguins
optdepends = xorg-fonts-100dpi: help support
source = https://www.delorie.com/store/ace/ace-1.4.tar.gz
source = ace14_fixes.patch
+ source = badmatch.patch
source = canfield.desktop
source = freecell.desktop
source = golf.desktop
@@ -29,6 +30,7 @@ pkgbase = ace-of-penguins
source = thornq.desktop
md5sums = b80169fa59d69758bb9686f31a84ad2b
md5sums = 9a95690a7f04cce7009373c06c898812
+ md5sums = 9dd95179f01e019795d0532e29970967
md5sums = 10589ed7a16e62f128daf627aed08800
md5sums = 05f94f8737b2b5993c3d7b4acaea94a0
md5sums = 1cea6b83041c42061145776507aea602
diff --git a/PKGBUILD b/PKGBUILD
index c7ceb9fd34fa..73e9875522ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=ace-of-penguins
_pkgname=ace
pkgver=1.4
-pkgrel=5
+pkgrel=6
pkgdesc="A set of Unix/X solitaire games."
arch=('i686' 'x86_64' 'aarch64')
url="https://www.delorie.com/store/ace/"
@@ -15,6 +15,7 @@ depends=('libx11' 'libxpm' 'libpng' 'zlib')
optdepends=('xorg-fonts-100dpi: help support')
source=("https://www.delorie.com/store/ace/$_pkgname-$pkgver.tar.gz"
"ace14_fixes.patch"
+ "badmatch.patch"
"canfield.desktop"
"freecell.desktop"
"golf.desktop"
@@ -31,6 +32,7 @@ source=("https://www.delorie.com/store/ace/$_pkgname-$pkgver.tar.gz"
)
md5sums=('b80169fa59d69758bb9686f31a84ad2b'
'9a95690a7f04cce7009373c06c898812'
+ '9dd95179f01e019795d0532e29970967'
'10589ed7a16e62f128daf627aed08800'
'05f94f8737b2b5993c3d7b4acaea94a0'
'1cea6b83041c42061145776507aea602'
@@ -48,6 +50,7 @@ md5sums=('b80169fa59d69758bb9686f31a84ad2b'
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -p1 -i "${srcdir}"/ace14_fixes.patch
+ patch -p1 -i "${srcdir}"/badmatch.patch
LDFLAGS="$LDFLAGS -lpng -lz -lm" ./configure --prefix=/usr
make
}
diff --git a/badmatch.patch b/badmatch.patch
new file mode 100644
index 000000000000..dbb9dbdfb3c4
--- /dev/null
+++ b/badmatch.patch
@@ -0,0 +1,11 @@
+-- ace14/lib/table.c 2012-03-24 14:00:49.000000000 -0400
++++ ace-1.4/lib/table.c 2022-11-21 05:36:11.183763096 -0500
+@@ -216,7 +216,7 @@
+ printf("copy clip: x=%3d y=%3d w=%3d h=%3d (ex=%d ey=%d ew=%d eh=%d)\n",
+ dx+x, dy+y, w, h, ex, ey, ew, eh);
+ #endif
+- if (w>0 && h>0)
++ if (w>0 && h>0 && !(w == 1 && h == 1 && (dx+x) == 0 && (dy+y) == 0))
+ {
+ #if TRACE_PICTURES
+ printf("copy aft: x=%3d y=%3d w=%3d h=%3d\n", dx+x, dy+y, w, h);