summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:07:42 +0100
committerSteven Honeyman2015-06-09 19:07:42 +0100
commita7b285d0ebdfb5c2f9f41b102a950a5afba9fcaa (patch)
tree299d372a944c1e38c15e135fd5afd3adaffa4c81
downloadaur-a7b285d0ebdfb5c2f9f41b102a950a5afba9fcaa.tar.gz
Initial import
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD48
-rwxr-xr-xace14_fixes.patch57
-rw-r--r--canfield.desktop9
-rw-r--r--freecell.desktop9
-rw-r--r--golf.desktop9
-rw-r--r--mastermind.desktop9
-rw-r--r--merlin.desktop9
-rw-r--r--minesweeper.desktop9
-rw-r--r--pegged.desktop9
-rw-r--r--penguins.desktop9
-rw-r--r--solitaire.desktop9
-rw-r--r--spider.desktop9
-rw-r--r--taipei-editor.desktop9
-rw-r--r--taipei.desktop9
-rw-r--r--thornq.desktop9
16 files changed, 268 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a94b90274b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = ace-of-penguins
+ pkgdesc = A set of Unix/X solitaire games.
+ pkgver = 1.4
+ pkgrel = 3
+ url = http://www.delorie.com/store/ace/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libx11
+ depends = libxpm
+ depends = libpng
+ depends = zlib
+ optdepends = xorg-fonts-100dpi: help support
+ source = http://www.delorie.com/store/ace/ace-1.4.tar.gz
+ source = ace14_fixes.patch
+ source = canfield.desktop
+ source = freecell.desktop
+ source = golf.desktop
+ source = mastermind.desktop
+ source = merlin.desktop
+ source = minesweeper.desktop
+ source = pegged.desktop
+ source = penguins.desktop
+ source = solitaire.desktop
+ source = spider.desktop
+ source = taipei.desktop
+ source = taipei-editor.desktop
+ source = thornq.desktop
+ md5sums = b80169fa59d69758bb9686f31a84ad2b
+ md5sums = 371587c1841ba7fe8c41940b71079edc
+ md5sums = 10589ed7a16e62f128daf627aed08800
+ md5sums = 05f94f8737b2b5993c3d7b4acaea94a0
+ md5sums = 1cea6b83041c42061145776507aea602
+ md5sums = 1ae4b64e486df5ced772a6f05948229e
+ md5sums = 143977d4730d08d45af83695a545e15f
+ md5sums = f53051130ad78fb1c44c386b38b4092f
+ md5sums = 6e97520466f05c46c7c64e09d760a190
+ md5sums = fe008f0b52ecb549d3fecde5bbc34cea
+ md5sums = 40d2c37e9acde31af7a17d70c8191786
+ md5sums = efffd817a86115b4ec2a42c1e6cf5af6
+ md5sums = 406c388089c52376dfc34a58f419c775
+ md5sums = 19fce2af99157a940454c868e9ed5c05
+ md5sums = d0a6754557f06c0b49fba303705379c5
+
+pkgname = ace-of-penguins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a9db05c3e4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+# Contributor: Antonio Bonifati
+# Contributor: renato
+pkgname=ace-of-penguins
+_pkgname=ace
+pkgver=1.4
+pkgrel=3
+pkgdesc="A set of Unix/X solitaire games."
+arch=('i686' 'x86_64')
+url="http://www.delorie.com/store/ace/"
+license=('GPL')
+depends=('libx11' 'libxpm' 'libpng' 'zlib')
+optdepends=('xorg-fonts-100dpi: help support')
+source=(http://www.delorie.com/store/ace/$_pkgname-$pkgver.tar.gz
+ ace14_fixes.patch canfield.desktop freecell.desktop golf.desktop
+ mastermind.desktop merlin.desktop minesweeper.desktop pegged.desktop
+ penguins.desktop solitaire.desktop spider.desktop taipei.desktop
+ taipei-editor.desktop thornq.desktop)
+md5sums=('b80169fa59d69758bb9686f31a84ad2b'
+ '371587c1841ba7fe8c41940b71079edc'
+ '10589ed7a16e62f128daf627aed08800'
+ '05f94f8737b2b5993c3d7b4acaea94a0'
+ '1cea6b83041c42061145776507aea602'
+ '1ae4b64e486df5ced772a6f05948229e'
+ '143977d4730d08d45af83695a545e15f'
+ 'f53051130ad78fb1c44c386b38b4092f'
+ '6e97520466f05c46c7c64e09d760a190'
+ 'fe008f0b52ecb549d3fecde5bbc34cea'
+ '40d2c37e9acde31af7a17d70c8191786'
+ 'efffd817a86115b4ec2a42c1e6cf5af6'
+ '406c388089c52376dfc34a58f419c775'
+ '19fce2af99157a940454c868e9ed5c05'
+ 'd0a6754557f06c0b49fba303705379c5')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 -i "$srcdir"/ace14_fixes.patch
+ LDFLAGS="$LDFLAGS -lpng -lz -lm" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install-strip
+ for G in "$srcdir"/*.desktop; do
+ install -Dm644 $G "${pkgdir}"/usr/share/applications/$(basename $G)
+ done
+}
diff --git a/ace14_fixes.patch b/ace14_fixes.patch
new file mode 100755
index 000000000000..df1137dc9f93
--- /dev/null
+++ b/ace14_fixes.patch
@@ -0,0 +1,57 @@
+--- ace14/lib/xwin.c
++++ ace-1.4/lib/xwin.c
+@@ -89,10 +89,10 @@
+ /* Motif window hints */
+ typedef struct
+ {
+- unsigned flags;
+- unsigned functions;
+- unsigned decorations;
+- int inputMode;
++ unsigned long flags;
++ unsigned long functions;
++ unsigned long decorations;
++ long inputMode;
+ } PropMotifWmHints;
+
+ typedef PropMotifWmHints PropMwmHints;
+@@ -841,13 +841,13 @@
+ png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
+ info_ptr = png_create_info_struct (png_ptr);
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf (png_ptr))) {
+ fprintf(stderr, "Invalid PNG image!\n");
+ return;
+ }
+
+ file_bytes = src->file_data;
+- png_set_read_fn (png_ptr, (voidp)&file_bytes, (png_rw_ptr)png_reader);
++ png_set_read_fn (png_ptr, (void *)&file_bytes, (png_rw_ptr)png_reader);
+
+ png_read_info (png_ptr, info_ptr);
+
+--- ace14/lib/make-imglib.c
++++ ace-1.4/lib/make-imglib.c
+@@ -86,7 +86,7 @@
+ png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
+ info_ptr = png_create_info_struct (png_ptr);
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf (png_ptr))) {
+ fclose (f);
+ continue;
+ }
+
+--- ace14/lib/Makefile.am
++++ ace-1.4/lib/Makefile.am
+@@ -6,7 +6,7 @@
+ CLEANFILES = images.c images.d
+
+ INCLUDES = $(X_CFLAGS) @PDA@
+-AM_LDFLAGS = $(X_LIBS)
++AM_LDFLAGS = $(X_LIBS) -lpng -lz -lm
+
+ BUILD_CC = @BUILD_CC@
+ AR = @AR@
+
diff --git a/canfield.desktop b/canfield.desktop
new file mode 100644
index 000000000000..4b754c5fdcba
--- /dev/null
+++ b/canfield.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Canfield
+GenericName=
+Comment=Solitary card-game
+Icon=
+Exec=/usr/bin/canfield
+Terminal=false
+Categories=Game;BoardGame;
diff --git a/freecell.desktop b/freecell.desktop
new file mode 100644
index 000000000000..e0944d23a27c
--- /dev/null
+++ b/freecell.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Freecell
+GenericName=
+Comment=Solitary card-game
+Icon=
+Exec=/usr/bin/freecell
+Terminal=false
+Categories=Game;CardGame;
diff --git a/golf.desktop b/golf.desktop
new file mode 100644
index 000000000000..46d79ae79b24
--- /dev/null
+++ b/golf.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Golf
+GenericName=
+Comment=Another solitary card-game
+Icon=
+Exec=/usr/bin/golf
+Terminal=false
+Categories=Game;CardGame;
diff --git a/mastermind.desktop b/mastermind.desktop
new file mode 100644
index 000000000000..6bc225adac60
--- /dev/null
+++ b/mastermind.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Mastermind
+GenericName=
+Comment=Guess a secret combination of colors
+Icon=
+Exec=/usr/bin/mastermind
+Terminal=false
+Categories=Game;LogicGame;
diff --git a/merlin.desktop b/merlin.desktop
new file mode 100644
index 000000000000..c3f0c23f4707
--- /dev/null
+++ b/merlin.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Merlin
+GenericName=
+Comment=Classical puzzle
+Icon=
+Exec=/usr/bin/merlin
+Terminal=false
+Categories=Game;LogicGame;
diff --git a/minesweeper.desktop b/minesweeper.desktop
new file mode 100644
index 000000000000..8828cbbe61e8
--- /dev/null
+++ b/minesweeper.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Minesweeper
+GenericName=
+Comment=Find all hidden mines in a minefield
+Icon=
+Exec=/usr/bin/minesweeper
+Terminal=false
+Categories=Game;LogicGame;
diff --git a/pegged.desktop b/pegged.desktop
new file mode 100644
index 000000000000..22291a75f823
--- /dev/null
+++ b/pegged.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Pegged
+GenericName=
+Comment=Classical board game
+Icon=
+Exec=/usr/bin/pegged
+Terminal=false
+Categories=Game;LogicGame;
diff --git a/penguins.desktop b/penguins.desktop
new file mode 100644
index 000000000000..4636a797d659
--- /dev/null
+++ b/penguins.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Penguins
+GenericName=
+Comment=Solitary card-game
+Icon=
+Exec=/usr/bin/penguins
+Terminal=false
+Categories=Game;CardGame;
diff --git a/solitaire.desktop b/solitaire.desktop
new file mode 100644
index 000000000000..c623dfe15390
--- /dev/null
+++ b/solitaire.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Solitaire
+GenericName=
+Comment=Solitary card-game
+Icon=
+Exec=/usr/bin/solitaire
+Terminal=false
+Categories=Game;CardGame;
diff --git a/spider.desktop b/spider.desktop
new file mode 100644
index 000000000000..9431e18f79ba
--- /dev/null
+++ b/spider.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Spider
+GenericName=
+Comment=Solitary card-game
+Icon=
+Exec=/usr/bin/spider
+Terminal=false
+Categories=Game;BoardGame;
diff --git a/taipei-editor.desktop b/taipei-editor.desktop
new file mode 100644
index 000000000000..c2fdd7dc58d3
--- /dev/null
+++ b/taipei-editor.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Taipei-Editor
+GenericName=
+Comment=Editor for your own taipei levels
+Icon=
+Exec=/usr/bin/taipedit
+Terminal=false
+Categories=Game;BoardGame;
diff --git a/taipei.desktop b/taipei.desktop
new file mode 100644
index 000000000000..afb363d30395
--- /dev/null
+++ b/taipei.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Taipei
+GenericName=
+Comment=Asian puzzle, remove pairs of equal stones
+Icon=
+Exec=/usr/bin/taipei
+Terminal=false
+Categories=Game;BoardGame;
diff --git a/thornq.desktop b/thornq.desktop
new file mode 100644
index 000000000000..9f47907ad923
--- /dev/null
+++ b/thornq.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Penguin Thornq
+GenericName=
+Comment=Solitary card-game
+Icon=
+Exec=/usr/bin/thornq
+Terminal=false
+Categories=Game;CardGame;