summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Magnus Brevik2017-04-13 02:57:41 +0200
committerJan Magnus Brevik2017-04-13 02:57:41 +0200
commit034f431749fa76a2aee9151de3ed98bae313c700 (patch)
tree3ce7fef65a5d82d78ece53de38a1a2a73aa72b54
parent65c5f1afb5ac5e2f536195b9cafb6da2e13ea1e0 (diff)
downloadaur-034f431749fa76a2aee9151de3ed98bae313c700.tar.gz
updated 3.1.16
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
-rw-r--r--acestream-engine.install2
3 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3b886f6790f..26eb4957f272 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = acestream-engine
pkgdesc = ACE Stream engine
- pkgver = 3.0.5.1
- pkgrel = 2
+ pkgver = 3.1.16
+ pkgrel = 1
url = http://acestream.org/
install = acestream-engine.install
- arch = i686
arch = x86_64
license = unknown
depends = python2-setuptools
@@ -13,10 +12,9 @@ pkgbase = acestream-engine
depends = python2-apsw
optdepends = libappindicator-gtk2: GTK+ gui support
source = acestream-engine.service
+ source = http://dl.acestream.org/linux/acestream_3.1.16_ubuntu_16.04_x86_64.tar.gz
sha256sums = b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0
- source_i686 = http://dl.acestream.org/ubuntu/14/acestream_3.0.5.1_ubuntu_14.04_i686.tar.gz
- source_x86_64 = http://dl.acestream.org/ubuntu/14/acestream_3.0.5.1_ubuntu_14.04_x86_64.tar.gz
- sha256sums_x86_64 = 5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397
+ sha256sums = 452bccb8ae8b5ff4497bbb796081dcf3fec2b699ba9ce704107556a3d6ad2ad7
pkgname = acestream-engine
diff --git a/PKGBUILD b/PKGBUILD
index 33651e989262..6f45cebb4be4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Rubén Fdes Moreira <tmp-meteque@openmailbox.com>
+# Maintainer: Jan Magnus Brevik <janmbrevik at gmail dot com>
+# Contributor: Rubén Fdes Moreira <tmp-meteque@openmailbox.com>
# Contributor: Sigmund Vestergaard <sigmundv at gmail dot com>
# Contributor: MacCyber <jonas.enge at gmail dot com>
# Contributor: Doug Newgard <scimmia22 at outlook dot com>
@@ -6,29 +7,28 @@
# Contributor: Antti Hautaniemi <an7oine at me com>
pkgname=acestream-engine
-pkgver=3.0.5.1
-[[ "$CARCH" == i686 ]] && pkgver=3.0.3
-pkgrel=2
-_ubuntuver=14.04
+pkgver=3.1.16
+pkgrel=1
+_ubuntuver=16.04
pkgdesc="ACE Stream engine"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://acestream.org/"
license=('unknown')
depends=('python2-setuptools' 'python2-xlib' 'python2-m2crypto' 'python2-apsw')
optdepends=('libappindicator-gtk2: GTK+ gui support')
install='acestream-engine.install'
-source=('acestream-engine.service')
-source_x86_64=("http://dl.acestream.org/ubuntu/${_ubuntuver%.*}/acestream_${pkgver}_ubuntu_${_ubuntuver}_x86_64.tar.gz")
-source_i686=("http://dl.acestream.org/ubuntu/${_ubuntuver%.*}/acestream_${pkgver}_ubuntu_${_ubuntuver}_i686.tar.gz")
-
-sha256sums=('b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0')
-sha256sums_x86_64=('5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397')
+source=("acestream-engine.service"
+ "http://dl.acestream.org/linux/acestream_${pkgver}_ubuntu_${_ubuntuver}_x86_64.tar.gz")
+sha256sums=('b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0'
+ '452bccb8ae8b5ff4497bbb796081dcf3fec2b699ba9ce704107556a3d6ad2ad7')
package() {
cd "$srcdir/acestream_${pkgver}_ubuntu_${_ubuntuver}_$CARCH"
- install -Dm755 acestreamengine "$pkgdir/usr/bin/acestreamengine"
- install -d "$pkgdir/usr/share/acestream/"
- cp -a data lib "$pkgdir/usr/share/acestream/"
+ install -Dm755 acestreamengine "$pkgdir/opt/acestream/acestreamengine"
+ sed -i "/ROOT=/c\ROOT=\/opt\/acestream" "start-engine"
+ install -Dm755 "start-engine" "$pkgdir/opt/acestream/start-engine"
+ cp -a acestream.conf "$pkgdir/opt/acestream/acestream.conf"
+ cp -a data lib "$pkgdir/opt/acestream/"
install -Dm644 "$srcdir/acestream-engine.service" "$pkgdir/usr/lib/systemd/system/acestream-engine.service"
}
diff --git a/acestream-engine.install b/acestream-engine.install
index 38fe9eecc240..bcedb3aa012d 100644
--- a/acestream-engine.install
+++ b/acestream-engine.install
@@ -2,6 +2,7 @@ post_install() {
if ! getent passwd acestream &> /dev/null; then
useradd -u 4035 -g video -m -s /usr/bin/nologin acestream
fi
+ ln -sf /opt/acestream/start-engine /usr/bin/acestreamengine
}
post_upgrade() {
@@ -12,4 +13,5 @@ post_remove() {
if getent passwd acestream &>/dev/null; then
userdel acestream
fi
+ rm -f /usr/bin/acestreamengine
}