summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubén F. Moreira2016-10-01 18:37:02 +0200
committerRubén F. Moreira2016-10-01 18:37:02 +0200
commit65c5f1afb5ac5e2f536195b9cafb6da2e13ea1e0 (patch)
tree388b5a5de41295fbebab8332d816230d618b9bcd
parent3f278d211969224fa93f39c4b5ce0b88fbb1a02f (diff)
downloadaur-65c5f1afb5ac5e2f536195b9cafb6da2e13ea1e0.tar.gz
i386 support
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3de1ff35d29..b3b886f6790f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = acestream-engine
pkgdesc = ACE Stream engine
pkgver = 3.0.5.1
- pkgrel = 1
+ pkgrel = 2
url = http://acestream.org/
install = acestream-engine.install
+ arch = i686
arch = x86_64
license = unknown
depends = python2-setuptools
@@ -12,9 +13,10 @@ pkgbase = acestream-engine
depends = python2-apsw
optdepends = libappindicator-gtk2: GTK+ gui support
source = acestream-engine.service
- source = http://dl.acestream.org/ubuntu/14/acestream_3.0.5.1_ubuntu_14.04_.tar.gz
sha256sums = b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0
- sha256sums = 5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397
+ source_i686 = http://dl.acestream.org/ubuntu/14/acestream_3.0.5.1_ubuntu_14.04_i686.tar.gz
+ source_x86_64 = http://dl.acestream.org/ubuntu/14/acestream_3.0.5.1_ubuntu_14.04_x86_64.tar.gz
+ sha256sums_x86_64 = 5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397
pkgname = acestream-engine
diff --git a/PKGBUILD b/PKGBUILD
index 5ab1adda35d6..33651e989262 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: Rubén Fdes Moreira <tmp-meteque@openmailbox.com>
# Contributor: Sigmund Vestergaard <sigmundv at gmail dot com>
# Contributor: MacCyber <jonas.enge at gmail dot com>
# Contributor: Doug Newgard <scimmia22 at outlook dot com>
@@ -6,20 +7,24 @@
pkgname=acestream-engine
pkgver=3.0.5.1
-pkgrel=1
+[[ "$CARCH" == i686 ]] && pkgver=3.0.3
+pkgrel=2
_ubuntuver=14.04
pkgdesc="ACE Stream engine"
-arch=('x86_64')
+arch=('i686' 'x86_64')
url="http://acestream.org/"
license=('unknown')
depends=('python2-setuptools' 'python2-xlib' 'python2-m2crypto' 'python2-apsw')
optdepends=('libappindicator-gtk2: GTK+ gui support')
install='acestream-engine.install'
-source=('acestream-engine.service'
- "http://dl.acestream.org/ubuntu/${_ubuntuver%.*}/acestream_${pkgver}_ubuntu_${_ubuntuver}_$CARCH.tar.gz")
-sha256sums=('b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0'
- '5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397')
-
+
+source=('acestream-engine.service')
+source_x86_64=("http://dl.acestream.org/ubuntu/${_ubuntuver%.*}/acestream_${pkgver}_ubuntu_${_ubuntuver}_x86_64.tar.gz")
+source_i686=("http://dl.acestream.org/ubuntu/${_ubuntuver%.*}/acestream_${pkgver}_ubuntu_${_ubuntuver}_i686.tar.gz")
+
+sha256sums=('b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0')
+sha256sums_x86_64=('5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397')
+
package() {
cd "$srcdir/acestream_${pkgver}_ubuntu_${_ubuntuver}_$CARCH"
install -Dm755 acestreamengine "$pkgdir/usr/bin/acestreamengine"