summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonian Guveli2018-11-06 16:50:36 +0200
committerJonian Guveli2018-11-06 16:50:36 +0200
commit8625bb63718eb08453e07c2c2ea823d187bf6098 (patch)
tree49a9b11f05be762a7d4622f1b0e90cf51c55315b
parent5bfa9d165b427902b73d49f7da15019cb73a6ae0 (diff)
downloadaur-8625bb63718eb08453e07c2c2ea823d187bf6098.tar.gz
version update and package optimization
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20f86a2e1ec2..f5e3d9896b77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = acestream-launcher
pkgdesc = Acestream Launcher allows you to open Acestream links with a Media Player of your choice
- pkgver = 1.2.1
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/jonian/acestream-launcher
arch = any
@@ -11,8 +11,8 @@ pkgbase = acestream-launcher
optdepends = mpv
optdepends = libnotify
provides = acestream-launcher
- source = acestream-launcher-1.2.1::https://github.com/jonian/acestream-launcher/archive/v1.2.1.tar.gz
- md5sums = 3f2e2f9bde3d21651dec7b4caa22def2
+ source = acestream-launcher-1.3.0.tar.gz::https://github.com/jonian/acestream-launcher/archive/v1.3.0.tar.gz
+ md5sums = d41fda9e8995967242d73db797257b14
pkgname = acestream-launcher
diff --git a/PKGBUILD b/PKGBUILD
index 029c4aaef67c..b5fb0b9c7fe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonian Guveli <https://github.com/jonian/>
pkgname=acestream-launcher
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
pkgdesc="Acestream Launcher allows you to open Acestream links with a Media Player of your choice"
arch=("any")
@@ -10,18 +10,17 @@ depends=("python" "acestream-engine")
optdepends=("mpv" "libnotify")
makedepends=("desktop-file-utils")
provides=("acestream-launcher")
-source=("$pkgname-$pkgver::https://github.com/jonian/acestream-launcher/archive/v$pkgver.tar.gz")
-md5sums=("3f2e2f9bde3d21651dec7b4caa22def2")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+md5sums=("d41fda9e8995967242d73db797257b14")
package() {
- mkdir -p "$pkgdir/opt"
- mkdir -p "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/applications"
+ install -d "$pkgdir/opt"
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/applications"
cp -a "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/$pkgname"
+ ln -s "/opt/$pkgname/acestream_launcher.py" "$pkgdir/usr/bin/acestream-launcher"
+ mv -n "$pkgdir/opt/$pkgname/acestream-launcher.desktop" "$pkgdir/usr/share/applications/acestream-launcher.desktop"
update-desktop-database "$pkgdir/opt/$pkgname"
-
- ln -s "/opt/$pkgname/acestream_launcher.py" "$pkgdir/usr/bin/acestream-launcher"
- mv "$pkgdir/opt/$pkgname/acestream-launcher.desktop" "$pkgdir/usr/share/applications/acestream-launcher.desktop"
}