summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonian Guveli2015-12-05 15:45:34 +0200
committerJonian Guveli2015-12-05 15:45:34 +0200
commitb0cbcf6ab380cd4482ca8aedfc2136ba7b10e4b7 (patch)
tree1d85a46df407f0519531978ed194061d7e110c07
parent46d8fee9cd43b407c931cfac81859f3e4aedaa33 (diff)
downloadaur-b0cbcf6ab380cd4482ca8aedfc2136ba7b10e4b7.tar.gz
optimize code
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 15 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e4203a3492b..d378bbd14670 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Dec 5 13:41:06 UTC 2015
pkgbase = acestream-launcher
pkgdesc = Acestream Launcher allows you to open Acestream links with a Media Player of your choice
pkgver = 0.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jonian/acestream-launcher
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 27017106dc10..3fc1ab500a74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,27 @@
# Maintainer: Jonian Guveli <https://github.com/jonian/>
pkgname=acestream-launcher
pkgver=0.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Acestream Launcher allows you to open Acestream links with a Media Player of your choice"
-arch=('any')
+arch=("any")
url="https://github.com/jonian/acestream-launcher"
-license=('GPL')
-groups=()
-depends=('python-psutil' 'python-pexpect' 'python-ptyprocess' 'python-notify2' 'acestream-engine')
-makedepends=()
-optdepends=('vlc')
-provides=('acestream-launcher')
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
+license=("GPL")
+depends=("python-psutil" "python-pexpect" "python-ptyprocess" "python-notify2" "acestream-engine")
+optdepends=("vlc")
+provides=("acestream-launcher")
source=("https://github.com/jonian/acestream-launcher/archive/v$pkgver.tar.gz")
-noextract=()
-md5sums=('SKIP')
+md5sums=("SKIP")
package() {
mkdir -p "$pkgdir/opt"
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/applications"
- cp -a "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/acestream-launcher"
+ cp -a "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/$pkgname"
- update-desktop-database "$pkgdir/opt/acestream-launcher"
+ update-desktop-database "$pkgdir/opt/$pkgname"
- ln -s "/opt/acestream-launcher/acestream-launcher.py" "$pkgdir/usr/bin/acestream-launcher"
- mv "$pkgdir/opt/acestream-launcher/acestream-launcher.desktop" "$pkgdir/usr/share/applications/acestream-launcher.desktop"
+ ln -s "/opt/$pkgname/acestream-launcher.py" "$pkgdir/usr/bin/acestream-launcher"
+ mv "$pkgdir/opt/$pkgname/acestream-launcher.desktop" "$pkgdir/usr/share/applications/acestream-launcher.desktop"
}
+