summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2016-11-02 22:27:27 +0300
committersurefire2016-11-02 22:27:27 +0300
commit705106bb8ee05dc8de890b4fd7b6e08377f79345 (patch)
treedd3e87b1bf8fdfe22cd64fea352df4139f011734
parentcb8f8f9117c7c4eae570c865889c888b567c3c2d (diff)
downloadaur-705106bb8ee05dc8de890b4fd7b6e08377f79345.tar.gz
upgpkg: acme-client 0.1.13
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--bsd-cdefs.patch25
3 files changed, 4 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34e02160a3ed..7b8aef4cc54f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = acme-client-git
pkgdesc = Yet another ACME client, specifically for Let's Encrypt, but one with a strong focus on security. Written in C.
- pkgver = 0.1.12.r0.g2d209d4
+ pkgver = 0.1.13.r0.g4ff972e
pkgrel = 1
url = https://kristaps.bsd.lv/acme-client/
arch = x86_64
@@ -18,13 +18,11 @@ pkgbase = acme-client-git
source = acme@.timer
source = acme@.service
source = example.conf
- source = bsd-cdefs.patch
sha256sums = SKIP
sha256sums = bd5726f3e247e7a7d30ce69946d174b8fb92d999d22710c65f176c969812960e
sha256sums = c7d852229ae8a1b816ec476554c5d703a5513e6578a38672a52f7e7fca653b73
sha256sums = d6e274929979a385308f29b4f15a923ce888b57faca9925b6f46a995b2bfd662
sha256sums = 297cf2592b1baed8da591136334ab7fc1f4f64a6a093a1ac657ceaae45aa8583
- sha256sums = 0336ab833dc0332bbeaacf952d2dba41614de2cbc9f129b85334206ddb5082cd
pkgname = acme-client-git
diff --git a/PKGBUILD b/PKGBUILD
index f7f32e90f470..0c18eb0886db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=acme-client-git
_pkgname=acme-client
-pkgver=0.1.12.r0.g2d209d4
+pkgver=0.1.13.r0.g4ff972e
pkgrel=1
arch=('x86_64' 'i686')
license=('BSD')
@@ -15,15 +15,13 @@ source=(${pkgname}::'git+https://github.com/kristapsdz/acme-client-portable.git'
"http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-${_sslver}.tar.gz"
'acme@.timer'
'acme@.service'
- 'example.conf'
- 'bsd-cdefs.patch')
+ 'example.conf')
sha256sums=('SKIP'
'bd5726f3e247e7a7d30ce69946d174b8fb92d999d22710c65f176c969812960e'
'c7d852229ae8a1b816ec476554c5d703a5513e6578a38672a52f7e7fca653b73'
'd6e274929979a385308f29b4f15a923ce888b57faca9925b6f46a995b2bfd662'
- '297cf2592b1baed8da591136334ab7fc1f4f64a6a093a1ac657ceaae45aa8583'
- '0336ab833dc0332bbeaacf952d2dba41614de2cbc9f129b85334206ddb5082cd')
+ '297cf2592b1baed8da591136334ab7fc1f4f64a6a093a1ac657ceaae45aa8583')
depends=('libbsd')
makedepends=('git')
@@ -38,11 +36,6 @@ pkgver() {
git describe --long --tags | sed 's/VERSION_//;s/\([^-]*-g\)/r\1/;s/[-_]/./g'
}
-prepare() {
- cd "${pkgname}"
- patch -Np1 <../bsd-cdefs.patch
-}
-
build() {
cd "libressl-${_sslver}"
./configure --disable-shared --enable-static
diff --git a/bsd-cdefs.patch b/bsd-cdefs.patch
deleted file mode 100644
index 84676f212716..000000000000
--- a/bsd-cdefs.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/config.h b/config.h
-index 6187523..537933e 100644
---- a/config.h
-+++ b/config.h
-@@ -20,6 +20,7 @@
- # ifndef MUSL_LIBC
- # include <bsd/stdlib.h>
- # include <bsd/string.h>
-+# include <bsd/sys/cdefs.h>
- # else
- # include <errno.h>
- # include <unistd.h>
-diff --git a/main.c b/main.c
-index 1ccfe4a..45ef79d 100644
---- a/main.c
-+++ b/main.c
-@@ -120,7 +120,7 @@ xdup(int infd, int outfd)
- * Execute "newargs", which is already created in main(), as a
- * subprocess of type "comp".
- */
--static __dead void
-+static __dead2 void
- xrun(enum comp comp, const char **newargs)
- {
-