summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThor772018-12-30 13:21:39 +0100
committerThor772018-12-30 13:22:38 +0100
commit44da80544cb7e11c56484a8cb57109ae9a030507 (patch)
tree54954bb4b17efd7ee4f655ca6d29dadd4aac5085
downloadaur-44da80544cb7e11c56484a8cb57109ae9a030507.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
-rw-r--r--acme-dns.custom.service12
-rw-r--r--acme-dns.install6
-rw-r--r--acme-dns.sysusers1
-rw-r--r--acme-dns.tmpfiles4
7 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9ff0b6ff1b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = acme-dns-bin
+ pkgdesc = Limited DNS server with RESTful HTTP API to handle ACME DNS challenges easily and securely
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://github.com/joohoi/acme-dns
+ install = acme-dns.install
+ arch = x86_64
+ license = MIT
+ options = !strip
+ options = !emptydirs
+ source = acme-dns.custom.service
+ source = acme-dns.sysusers
+ source = acme-dns.tmpfiles
+ sha256sums = 848052f02c0214cc8191b8583af0fdde8d2c435013f75a3b07242df9bbe417fd
+ sha256sums = 31c038721ff674519a506418b0d70045e2c51115a78a5939743886c44ef5e1bb
+ sha256sums = 36b309e79422ddbaf6067f814c8bd69bd842cc662c3c9dbbf507ee5716282779
+ source_x86_64 = https://github.com/joohoi/acme-dns/releases/download/v0.6/acme-dns_0.6_linux_amd64.tar.gz
+ sha256sums_x86_64 = 5db9309343ae5b2cc082b7e79af5a9c735b182956ba2d52471046ba549121dc3
+
+pkgname = acme-dns-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd25bce9ea68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Thor77 <thor77 at thor77 dot org>
+# Contributor: lf <packages at lfcode dot ca>
+
+pkgname=acme-dns-bin
+_pkgname=acme-dns
+pkgver=0.6
+pkgrel=1
+pkgdesc="Limited DNS server with RESTful HTTP API to handle ACME DNS challenges easily and securely"
+arch=('x86_64')
+url="https://github.com/joohoi/acme-dns"
+license=('MIT')
+options=('!strip' '!emptydirs')
+install=acme-dns.install
+source=('acme-dns.custom.service' 'acme-dns.sysusers' 'acme-dns.tmpfiles')
+sha256sums=(
+ '848052f02c0214cc8191b8583af0fdde8d2c435013f75a3b07242df9bbe417fd'
+ '31c038721ff674519a506418b0d70045e2c51115a78a5939743886c44ef5e1bb'
+ '36b309e79422ddbaf6067f814c8bd69bd842cc662c3c9dbbf507ee5716282779'
+)
+source_x86_64=("https://github.com/joohoi/acme-dns/releases/download/v$pkgver/acme-dns_${pkgver}_linux_amd64.tar.gz")
+sha256sums_x86_64=('5db9309343ae5b2cc082b7e79af5a9c735b182956ba2d52471046ba549121dc3')
+
+package() {
+ cd $srcdir
+
+ install -Dm755 acme-dns "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 config.cfg "$pkgdir/etc/$_pkgname/config.cfg"
+ install -Dm644 "$srcdir/acme-dns.custom.service" "$pkgdir/usr/lib/systemd/system/$_pkgname.service"
+ install -Dm644 "$srcdir/acme-dns.sysusers" "$pkgdir/usr/lib/sysusers.d/$_pkgname.conf"
+ install -Dm644 "$srcdir/acme-dns.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf"
+}
diff --git a/acme-dns.custom.service b/acme-dns.custom.service
new file mode 100644
index 000000000000..25edf1137cfc
--- /dev/null
+++ b/acme-dns.custom.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Limited DNS server with RESTful HTTP API to handle ACME DNS challenges easily and securely
+After=network.target
+
+[Service]
+User=acme-dns
+Group=acme-dns
+AmbientCapabilities=CAP_NET_BIND_SERVICE
+ExecStart=/usr/bin/acme-dns
+
+[Install]
+WantedBy=multi-user.target
diff --git a/acme-dns.install b/acme-dns.install
new file mode 100644
index 000000000000..9c56ce78414b
--- /dev/null
+++ b/acme-dns.install
@@ -0,0 +1,6 @@
+#/bin/sh
+
+post_install() {
+ systemd-sysusers /usr/lib/sysusers.d/acme-dns.conf
+ systemd-tmpfiles --create /usr/lib/tmpfiles.d/acme-dns.conf
+}
diff --git a/acme-dns.sysusers b/acme-dns.sysusers
new file mode 100644
index 000000000000..98300a78c42d
--- /dev/null
+++ b/acme-dns.sysusers
@@ -0,0 +1 @@
+u telegraf - - /etc/telegraf
diff --git a/acme-dns.tmpfiles b/acme-dns.tmpfiles
new file mode 100644
index 000000000000..293eafb9749a
--- /dev/null
+++ b/acme-dns.tmpfiles
@@ -0,0 +1,4 @@
+d /var/lib/telegraf 0755 telegraf telegraf
+d /etc/telegraf 0755 telegraf telegraf
+x /var/lib/telegraf/*
+x /etc/telegraf/*