summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2017-10-09 14:06:22 +0200
committeraksr2017-10-09 14:06:22 +0200
commitc553f49843a952de87bdd2ce3d3d06c26d67b909 (patch)
tree87afed06ee7ff1b17cc683499a2e943da0b00873
downloadaur-acme-edit-git.tar.gz
Start.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fae9aee5302
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Oct 9 12:06:21 UTC 2017
+pkgbase = acme-edit-git
+ pkgdesc = A fuzz file finder/plumber for acme
+ pkgver = r7.4dda137
+ pkgrel = 1
+ url = https://github.com/mariusae/edit
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = go
+
+pkgname = acme-edit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25a5a2916c59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=acme-edit-git
+pkgver=r7.4dda137
+pkgrel=1
+epoch=
+pkgdesc="A fuzz file finder/plumber for acme "
+arch=('i686' 'x86_64')
+url="https://github.com/mariusae/edit"
+license=('BSD')
+categories=()
+groups=()
+depends=('')
+makedepends=('git' 'go')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+noextract=()
+_gourl=marius.ae/edit
+
+pkgver() {
+ GOPATH="$srcdir" go get -d ${_gourl}
+ cd "$srcdir/src/${_gourl}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ GOPATH="$srcdir" go get -fix -v ${_gourl}
+}
+
+check() {
+ GOPATH="$srcdir" go test -v -x ${_gourl}
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 bin/edit "$pkgdir/usr/bin/acme-edit"
+ install -Dm644 src/${_gourl}/README $pkgdir/usr/share/doc/${pkgname%-*}/README
+ install -Dm644 src/${_gourl}/LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}
+